Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Введите с клавиатуры два числа a и b . Если оба числа четные , то вычислите их сумки выведите результат на экран .если оба нечетные то найдите

10-11 класс

произведение этих чисел и выведите результат . Иначе, увеличить все числа в пять раз и выведите результаты

Ahmatgaleev 31 дек. 2016 г., 20:48:34 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
маринкоуихихи
31 дек. 2016 г., 22:45:41 (7 лет назад)

uses crt; 
var a, b, S, M, New, New1:integer;
begin
write('a = '); read(a);
write('b = '); read(b);
S:=a+b; M:=a*b; New:=5*a; New1:=5*b;
if ((a mod 2)<>0) and ((b mod 2)<>0) then write('M = ',M) 
 else if ((a mod 2)=0) and ((b mod 2)=0) then  write('S = ',S); 
  if ((a mod 2)=0) and ((b mod 2)<>0) then write('New = ',New); 
   if ((a mod 2)<>0) and ((b mod 2)=0) then write('New1 = ',New1);
end.

Описание:
S=сумма чисел. M=произведение чисел. New=увеличение числа в 5 раз,если 1-ое число четное. New1=увеличение числа в 5 раз,если 2-ое число четное.

Ответить

Другие вопросы из категории

Составить и реализовать на языке программирования алгоритм с использованием оператора цикла While. Вычислить сумму S=2/3+3/4+4/5+…n-1/n (значение

переменной n вводится с клавиатуры).
Рекомендуемый вид экрана:

Введите значение n:

Читайте также

Составьте программу для решения следующей задачи. Введите с клавиатуры два числа: N и M. Если оба числа больше 100, то замените каждое из них меньшим и

выведите результаты на экран. Если первое число положительное, а второе отрицательное, то уменьшите их в два раза и выведите результаты. Иначе, найдите и выведите среднее арифметическое этих чисел.

ПОМОГИТЕ ПОЖАЛУЙСТА!!!! Составьте программу для решения следующей задачи. Введите с клавиатуры два числа: N и M. Если оба числа больше 100, то замените

каждое из них меньшим и выведите результаты на экран. Если первое число положительное, а второе отрицательное, то уменьшите их в два раза и выведите результаты. Иначе, найдите и выведите среднее арифметическое этих чисел.

составьте блок-схему и программу для решения следующей задачи. Введите с клавиатуры два числа: к и л. Если они положительны, то замените каждое на квадрат

их суммы и выведите результаты на экран. Если все числа отрицательны, то каждое сделайте равным наименьшему и выведите результаты. Иначе, К приравняйте к 10, а Л - к 15 и выведите результаты

Составьте программу для решения следующей задачи. Введите с клавиатуры два числа: А и В. Если числа не равны, то замените каждое из них большим и выведите

результаты на экран. Если они равны, то найдите и выведите удвоенную сумму этих чисел.



Вы находитесь на странице вопроса "Введите с клавиатуры два числа a и b . Если оба числа четные , то вычислите их сумки выведите результат на экран .если оба нечетные то найдите", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.