Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Для заданной квадратной матрицы сформировать одномерный массив из её диагональных элементов.

10-11 класс

Bislantaymaskh 23 янв. 2014 г., 5:00:32 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Galina752
23 янв. 2014 г., 7:02:02 (10 лет назад)

Паскаль АВС:


Program  Ainur59;
uses crt;
const n=10;
var
  i,j:integer;
  matr:array[1..n,1..n] of integer;
  diag:array[1..n] of integer;
begin
  writeln('*** Alphaeus is thinking... ***');
  writeln('***          OK             ***');
  writeln('Для заданной квадратной матрицы сформировать одномерный массив из её диагональных элементов');
  randomize;
  writeln('Матрица: ');
  for i:=1 to n do
  begin
    for j:=1 to n do
    begin
      matr[i,j]:=random(100)-50;
      write(matr[i,j]:4,' ');
      if i=j then diag[i]:=matr[i,j];
    end;
    writeln();
  end;
  writeln();
  writeln('Mассив диагональных элементов:');
  for i:=1 to n do
    write(diag[i]:4,' ');
end.

Ответить

Другие вопросы из категории

Для кодирования букв О, Л, А, З, К используются двоичные коды чисел 0, 1, 2, 3 и 4 соответственно (с сохранением одного незначащего нуля в случае

одноразрядного представления). Если таким способом закодировать последовательность символов ЗАКОЛКА и записать результат в шестнадцатеричном коде, то получится:
1) 4531253 2) 9876 3) E832 4) 238E
----------------------------
Помогите,пожалуйста! Желательно с кратким решением,потому что самой понять тоже хочется)

248062 бит = сколько мб?
Исполнитель Черепашка выполняет программу:

для K от 1 до N выполнить
вперёд K
направо 90
кц
Ввести N и определить расстояние между начальным и конечным положением исполнителя.
Помогите решить на паскале

Читайте также

1.В произвольно заданном одномерном массиве ( случайные значения из отрезка -6 до 11 ) из 6 элементов, определить количество отрицательных, нулевых и

положитльных элементов.
2.
Сформируйте одномерный массив из 5 элементов (значения элементов укажт пользователь с клавиатуры). Обнулите значения всех элементов с нечетными индексами. Выведите значения одномерного массива в строку через пробел.

Написать программу на С++. Дана целочисленная квадратная матрица произвольной размерности. Сформировать одномерный массив, в который поместить элементы

двумерной матрицы, находящиеся над побочной диагонали; упорядочить их по возрастанию и найти их среднее арифметическое.

определить число элементов массива, больших К. По заданному условию сформировать одномерный массив, вывести на печать и произвести операции по обрабо

тке полученных компонентов массива. Исходными данными являются одномерный массив, элементы которого задаются с помощью датчика случайных чисел от -50 до +50 и целое положительное число К

1)дан одномерный массив из 5 элементов.найти сумму положительных элементов. 2)Дан одномерный массив из 7

элементов.Найти колличество четных положительных элементов.

3)Дан массив из 6 элементов.Найти произвдение положительных из них.



Вы находитесь на странице вопроса "Для заданной квадратной матрицы сформировать одномерный массив из её диагональных элементов.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.