Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите пожайлуста ) Даны два неравных числа a и b.Меньшее из этих чисел заменить полуссумой a и b а большее их полуразность..пожаалуйста помогите

10-11 класс

натусик44 04 янв. 2014 г., 14:50:47 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
сашня
04 янв. 2014 г., 16:28:04 (10 лет назад)

uses crt;
var a, b, c, i :integer;
begin
   clrscr;
   writeln ('Введите числа');
   readln (a, b);if a>b then
      writeln ('a = ', (a-b)/2:0:10, ' b = ', (a+b)/b:0:10);
   if a<b then
      writeln ('b = ', (a+b)/b:0:10, ' a = ', (a-b)/2:0:10);
end.

P.S. Надеюсь на благодарность и лучший ответ.

+ 0 -
Лайм16
04 янв. 2014 г., 19:15:31 (10 лет назад)

program qwertr;
var a,b,c: integer;
begin 
read (a,b)
if (a<b) then
begin 
c:=(a+b)/2;
end;
else
c:=(a-b)/2;
end;
write (c);
end.

+ 0 -
Fantickz
04 янв. 2014 г., 20:21:41 (10 лет назад)

паскаль

+ 0 -
АВМ768
04 янв. 2014 г., 21:25:26 (10 лет назад)

паскаль

+ 0 -
Bazarovaaleksa
04 янв. 2014 г., 23:40:18 (10 лет назад)

program useryou;

Ответить

Другие вопросы из категории

Для кодирования букв О, Л, А, З, К используются двоичные коды чисел 0, 1, 2, 3 и 4 соответственно (с сохранением одного незначащего нуля в случае

одноразрядного представления). Если таким способом закодировать последовательность символов ЗАКОЛКА и записать результат в шестнадцатеричном коде, то получится:
1) 4531253 2) 9876 3) E832 4) 238E
----------------------------
Помогите,пожалуйста! Желательно с кратким решением,потому что самой понять тоже хочется)

248062 бит = сколько мб?
Исполнитель Черепашка выполняет программу:

для K от 1 до N выполнить
вперёд K
направо 90
кц
Ввести N и определить расстояние между начальным и конечным положением исполнителя.
Помогите решить на паскале

Читайте также

1)По данному числу n вычислите сумму 2(1-1/3+1/5-1/7+...+(-1)n/(2n+1)). Формат входных данных: Вводится одно число n, не превосходящее 100000.

Формат выходных данных: Необходимо вывести значение выражения 2) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b,не дающие остаток c при делении на d 3) Подсчитайте, сколько среди данных N чисел нулей, четных чисел, нечетных чисел. Вводится число N, а затем N чисел. Необходимо вывести сначала число нулей, затем число четных и нечетных чисел 4) электронное устройство, выдает каждую секунду очередное число последовательности 1, 2, 2, 3, 3, 3, 4, 4, 4, 4, 5... Ввиду дороговизны электронных комплектующих вам поручено разработать эмулятор для этого устройства. Формат входных данных: Дано количество секунд (от 1 до 1000000), которые работает генератор после включения. Формат выходных данных: Результат работы генератора(пример 2 1 2 5 1 2 2 3 3) 5)Вклад в банке составляет x рублей. Ежегодно он увеличивается на p процентов, после чего дробная часть копеек отбрасывается. Каждый год сумма вклада становится больше. Определите, через сколько лет вклад составит не менее y рублей.Программа получает на вход три натуральных числа: x, p, y и должна вывести одно целое число 6)Исполнитель “Раздвоитель” преобразует натуральные числа. У него есть две команды: “Вычесть 1” и “Разделить на 2”, первая команда уменьшает число на 1, вторая команда уменьшает число в два раза, если оно чётное, иначе происходит ошибка.Дано два натуральных числа A и B (A>B). Напишите алгоритм для Развоителя, который преобразует число A в число B и при этом содержит минимальное число команд. Команды алгоритма нужно выводить по одной в строке, первая команда обозначается, как -1, вторая команда как :2.

3. Даны два неравных числа X и Y. Большее из них заменить на сумму этих чисел, а меньшее увеличить в три раза.

4. Известны периметр первого треугольника Р1, координаты вершин второго x1, y1, x2, y2,x3, y3 и длины сторон третьего – а3, в3, с3. Найти и вывести на экран периметр меньшего треугольника.

Алгоритмы ветвления

Даны два действительных числа X и Y, не равные друг другу. Заменить меньшее из этих чисел половиной их суммы, а большее – их удвоенным произведением.

Разработать схему алгоритма для решения этой задачи. Протестировать алгоритм на числах 5.5 и -4.3, а также на числах 1 и 14.5.

Помогите с задачками в паскале. Даны три положительных числа а, в, с. Проверить будут ли они сторонами треугольника. Если да то

вычислить площадь этого треугольника. Даны два действительных положительных числа х и у. Арифметические действия над числами пронумерованы (1 - сложение, 2 - вычитание, 3 - умножение, 4 - деление). Составить программу, которая по выведенному номеру выполняет то или иное действие над числами.



Вы находитесь на странице вопроса "Помогите пожайлуста ) Даны два неравных числа a и b.Меньшее из этих чисел заменить полуссумой a и b а большее их полуразность..пожаалуйста помогите", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.