Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

С клавиатуры вводятся два числа А и В. меньшее из этих чисел возвести в квадрат,а большее в куб. C++

10-11 класс

GoldyCat 13 июля 2013 г., 1:38:50 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Павел73
13 июля 2013 г., 2:16:24 (10 лет назад)

#include <iostream>
using namespace std;

int a, b;
void check(int a, int b);
int main()
{
    cout<<"Enter 2 numbers\n";
    cin>>a;
    cin>>b;
    check(a, b);
    system("pause");
    return 0;
}

void check(int a, int b)
{
     if (a>b)
     {
            a=a*a*a;
            b=b*b;
            }
            else
            {
                a=a*a;
                b=b*b*b;
                }
           
     cout<<a<<"\n";
     cout<<b<<"\n";
     }

Ответить

Другие вопросы из категории

Срочно! Составить программу!!!


Количество чисел задается пользователем:
чтобы найти среднее арифметическое надо:

1. запросить у пользователя сколько вводится чисел(N)
2. сравнить количество чисел с нулем
2.1 если количество чисел >0 (т. к. количество чисел должно быть натуральным), то:
2.1.1 т. к. мы будем находить сумму чисел, значит начальное значение следует приравнять 0
2.1.2 выполнять цикл мы будем N раз. В цикле мы должны:
2.1.2.1 запросить число(А)
2.1.2.2 к полученной сумме прибавить введенное число
2.1.3 найти среднее арифметическое введенных чисел
2.1.4 вывести полученное значение
2.2 если количество чисел <=0 то:
2.2.1 вывести сообщение об ошибке.

Упростить формулу (X<=>Y)*(x+y)
Написать программу на Pascale

Даны первые элементы и разности двух арифметических
прогрессий. Определить, в какой из них m-й
элемент больше (m - заданное целое
число).

Читайте также

С клавиатуры вводятся два числа x и y.

Найти разновидность z между большим и меньшим из них

С клавиатуры вводятся два числа x и y.

Найти разновидность z между большим и меньшим из них



Вы находитесь на странице вопроса "С клавиатуры вводятся два числа А и В. меньшее из этих чисел возвести в квадрат,а большее в куб. C++", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.