Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

дан массив А(20) сформировать новый массив В,который получается из А путем записи после каждого положительного элемента числа 10 массивы А и В

10-11 класс

распечатать.срочно надо помогите пожалуйста

Lolsotobas 02 июня 2014 г., 0:26:51 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Amyhartzler
02 июня 2014 г., 1:13:07 (9 лет назад)

var a:array[0..19] of integer;
b:array of integer;
i,k:integer;
begin
for i:=0 to 19 do begin
read(a[i]);
if a[i]>0 then begin k+=2; setlength(b,k); b[k-2]:=a[i]; b[k-1]:=10; end
else begin k+=1; setlength(b,k); b[k-1]:=a[i]; end;
end;
for i:=0 to 19 do
write(a[i],' ');
writeln;
for i:=0 to k-1 do
write(b[i],' ');
end.

Ответить

Другие вопросы из категории

1. Информационное сообщение объемом 1,5 Кбайта содержит 3072 символа. Сколько символов содержит алфавит, при помощи которого было записано это

сообщение?

2. Сообщение занимает 2 страницы и содержит 1116 Кбайты информации. На каждой странице записано 256 символов.

Какова мощность используемого алфавита?

3. Сколько килобайтов составляет сообщение, содержащее 12288 битов?

Парольная защита при входе в систему необходима для:

а)защиты компьютера от вирусов
б)предотвращения входа в систему постороннего пользователя
в)идентификации пользователя
2Укажите что из перечисленным относится к вредоносным программам:
а)трояны
б)сетевые черви
в)утилиты
Помогите выбрать правильные ответы

Читайте также

№1. Дан массив из 30-ти элементов. Каждый элемент может принимать целочисленные значения от 0 до 100. Напишите программу, которая позволит найти сумму

двузначных элементов массива, которые не оканчиваются на 3. №2. Дан массив из 100 элементов. Каждый элемент может принимать целочисленные значения от 1 до 500. Напишите программу, которая позволит найти и вывести минимальное значение среди элементов массива, которые делят максимальное значение элементов массива без остатка.

№1. Дан массив из 30-ти элементов. Каждый элемент может принимать целочисленные значения от -100 до 100. Напишите программу, которая позволит

подсчитать среднее арифметическое положительных элементов массива, которые кратны первому элементу массива. №2. Дан массив из 40 элементов. Каждый элемент может принимать целочисленные значения от 0 до 200. Напишите программу, которая позволит найти наиболее часто встречающийся элемент массива

Паскаль. 12.Дан массив А(3*4). Найти сумму первых отрицательных элементов в каждом столбце. 13.Даны два массива А(3*3)

и В(3*3). Вывести на экран тот из них, у которого меньше сумма элементов главной диагонали.

17.Дан массив А(3*4). Заменить все отрицательные элементы на противоположные.

Дан массив V[15] целочисленных элементов. Определить: 1)произведение элементов, занимающих 1,6,11 места в массиве. 2)сумму

элементов, занимающих четные места в массиве.

3)сформировать новый массив K [10] из элемаентов с 1 по 10 по формуле: K[i]=V[i]*2.

4)определить максимальный элемент массива K, его порядковый номер.

нужна программа, написанная, на языке програмирования Pascal.

Добрый день. Помогите пожалуйста решить две задачи... №1 Дан массив из 25 элементов,найти сумму 4-х наибольших и 4-х наименьших э

лементов. Результат распечатать в виде:

Сумма наибольших=

Сумма наименьших=

№2

Даны два массива по 30 элементов. Найти среднее арифмитическое для элементов 1-го массива,номера которых больше номера минимального элемента 2-го массива

Заранее спасибо



Вы находитесь на странице вопроса "дан массив А(20) сформировать новый массив В,который получается из А путем записи после каждого положительного элемента числа 10 массивы А и В", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.