Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Заполнить массив из 15 элементов 0 и 1 при помощи генератора случайных чисел. Определить количество нулей и единиц в массиве

5-9 класс

Ani666 26 нояб. 2014 г., 19:30:49 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
школотая
26 нояб. 2014 г., 22:30:18 (9 лет назад)

var 
  i, n, e: integer;
  k: array[1..15]of integer;
begin  
for i := 1 to 15 do
    begin
    k[i] := random(2);
    write(k[i],' ');
    if k[i]=0 then n:=n+1
      else e:=e+1;
    end;
writeln;  
writeln('Нулей: ',n,'; единиц: ',e)
end.

Ответить

Другие вопросы из категории

частина гипертекстового документу указивающая на інший елемент в самом документе,

або на на інший обєкт, або на елементи цього обекта

Здравствуйте помогите пожалуйста!

Информатика 9 класс!

Читайте также

1). Дан массив из n элементов (n >= 4). Подсчитать среднюю арифметическую второго и предпоследнего элемента массива.

2). Дан массив из n элементов. Написать программу подсчитывающую произведение элементов массива.

решить через паскаль через массивы)) 1.Дан одномерный массив из 10 элементов. Заменить все большие 7 члены массива числом 7. Найти количество

таких членов.

2.Дан массив из 10 элементов. Найти количество элементов с четными индексами.

3.Дан массив из 10 элементов. Найти наибольший элемент массива.

1 Задание:сформируйте и выведите на экран массив из девяти элементов,каждые три последовательных элемента которого составлены по следующему правилу:

1-й равен значению текущего индекса, увеличенному на 3; 2-й равен квадрату предыдущего индекса; 3-й равен сумме двух предыдущих элементов. 2 Задание : сформируйте массив, содержащий 15 элементов ,с помощью датчику случайных чисел. Получите новый массив,каждый элемент которого равен сумме соответствующего элемента исходного массива и его индекса. В полученном массиве удвойте элементы,которые меньше заданного с клавиатуры числа А,и найдите их сумму . Выведите на экран исходные и полученные результаты .



Вы находитесь на странице вопроса "Заполнить массив из 15 элементов 0 и 1 при помощи генератора случайных чисел. Определить количество нулей и единиц в массиве", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.