Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Составьте программу, которая формирует массив из пятнадцати случайных целых чисел от -20 до 20 и отрицательные числа возводит в квадрат, а из

5-9 класс

неотрицательных извлекает квадратный корень.

Adyil 05 июня 2014 г., 0:08:00 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Tahka200
05 июня 2014 г., 2:16:34 (9 лет назад)

program rp1;
uses crt;
var a: array [1..15] of integer; i: integer;
begin
clrscr;
randomize;a[i]:=random (41)-20;
writeln ('massiv ');
for i:=1 to 15 do
write (a[i], ' ');
for i:=1 to 15 do
if a[i]< 0 then a[i]:=sqr (a[i]) else a[i]:=sqrt (a[i]);
writeln ('novij massiv ');
for i:=1 to 15 do
write (a[i], ' ');
end.

Ответить

Другие вопросы из категории

Читайте также

составьте программу , которая формирует массив из шестнадцати случайных целых чисел от -20 до 20

и подсчитывает количество отрицательных элементов.
язык Pascal abc

Помогите,пожалуйста,написать программу по информатике.Вот такое условие:

Составьте программу, которая формирует массив из 40 случайных целых чисел от 0 до 20 и вычисляет:
1). сумму чисел, не превышающих 10;
2). сумму чисел,кратных 3. Помогите пожалуйста,написать эту программу на PaskalABC.



Вы находитесь на странице вопроса "Составьте программу, которая формирует массив из пятнадцати случайных целых чисел от -20 до 20 и отрицательные числа возводит в квадрат, а из", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.