Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

написать программу выдающую след инф:средний балл полученный студентом и всей его группой в целом(poscal)

1-4 класс

Grinyaserg 10 сент. 2016 г., 16:28:15 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Naqirol
10 сент. 2016 г., 19:21:11 (7 лет назад)

фух задолбаюсь конечно писать))

Program name;
uses crt;
var x,y,k:integer;
s:real;
begin
clrscr;
y:=0
k:=0
while x>0 do;
begin
writeln(`введите одну оценку студента. если оценки кончились поставьте 0`);
readln(x)
y:=y+x;
k:=k+1;
end;
s:=y/k;
writeln(s);
readkey;
end.


я уверен что это правильно но эта программа ток для одного студента. если нужно для всей группы искать тоже то легче для неё отдельно точно такую же прогу составить но вместо пояснения в первом врайтлн написать нужно не про оценку а про введите средний балл каждого студента. если студенты кончились ставьте ноль,

а если нужно все уместить в одном то добавляешь ещё 3 переменные интеджер и 1 в Реал и после врайтлн(s) пишешь заново с другими переменными. ну заново это со слова Бегин ток его не пиши)

Ответить

Другие вопросы из категории

фирма" Электронные приборы" выпустила автоматизированную ванну" Банный комплекс- 21" пульт управления которой представлен на рисунке Однако в

результате ошибки фирмы все кнопки, кроме " Долить 5 л" и " Слить 3 л" не работают. Напишите программу, позволяющую долить в ванну следующие количества воды:

3 литра

Сколько воды пропало впустую из-за брака фирмы?

Помогите пожалуйста...

Читайте также

Даны числа: x, y. Вычислите: z=x+y, если

x \leq y, и z=x-y в противном случае.

Написать программу в паскале.

Как-то раз, придя домой со школы, Света обнаружила записку от мамы, в которой она просила сделать салат. Света знала, что салат – это смесь двух или более

ингредиентов, поэтому ей не составило труда выполнить мамину просьбу.Но Света хочет стать математиком, поэтому, для тренировки, решила посчитать, сколько различных салатов она сможет сделать из имеющихся продуктов (майонез, огурцы, помидоры). После небольших расчетов она получила ответ: 4.Зная, что вы любите интересные задачки, и хотите стать программистами, Света попросила вас написать программу, которая определяет количество различных салатов для произвольного числа ингредиентов.

Найти максимальный элемент массива X(10).

помогите написать программу в паскале пожалуйста.



Вы находитесь на странице вопроса "написать программу выдающую след инф:средний балл полученный студентом и всей его группой в целом(poscal)", категории "информатика". Данный вопрос относится к разделу "1-4" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.