Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

С клавиатуры вводятся оценки учащихся. Подсчитать количество сдавших экзамен (получили оценку не менее 3) и не сдавших предмет(получили 2).

5-9 класс

Программа Паскаль. Тема- цикл с пред условием .
СРОЧНО:)

КотШредингера 05 мая 2014 г., 1:47:35 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
каааааатя
05 мая 2014 г., 4:23:26 (10 лет назад)

program maxx;
var max,n,k,i:integer;
begin
writeln('введите кол-во чисел');
readln(k);
max:=0;
for i:=1 to k do
begin
readln(n);
if n>max then max:=n;
end;
writeln(max);
end.

+ 0 -
Cat92
05 мая 2014 г., 5:46:23 (10 лет назад)

Когда вводят последнюю цифру ставят ноль для окончания программы ?

+ 0 -
Owkas
05 мая 2014 г., 7:44:06 (10 лет назад)

нет

+ 0 -
сяпа2002
05 мая 2014 г., 10:00:36 (10 лет назад)

а как программа должна понять то что это последняя оценка ?

Ответить

Читайте также

Дан целочисленный массив из 30 элементов. Элементы могут принимать значения от 0 до 100 – баллы, полученные на ЕГЭ. Опишите на русском языке или

на одном из языков программирования алгоритм, который подсчитывает и выводит средний балл учащихся, сдавших экзамен (получивших оценку более 20 баллов). Гарантируется, что хотя бы один ученик в классе успешно сдал экзамен.

1, С клавиатуры вводятся 10 натуральных чисел. Вычислить сумму четных элементов.

2, С клавиатуры вводятся 15 натуральных чисел. Подсчитать количество элементов, кратных 3 и 5.
3, С клавиатуры вводятся 10 натуральных чисел. Вычислить произведение чисел, больших 10, но меньших 20.

1, С клавиатуры вводятся 10 натуральных чисел. Вычислить сумму четных элементов.

2, С клавиатуры вводятся 15 натуральных чисел. Подсчитать количество элементов, кратных 3 и 5.
3, С клавиатуры вводятся 10 натуральных чисел. Вычислить произведение чисел, больших 10, но меньших 20.

с клавиатуры вводится число х. если

с клавиатуры вводится число х. если остаток от деления х на 6 равен 2, то значение f(x)=4*x^2 если остаток от деления х на 6 равен 3, то значение f(x) = корень из х , если остаток от деления на 6 =0 то f(x) = x.


Написать программу в паскале используя операторы if и else . Нарисовать блок схему

1)В диапазоне от 0 до 100 подсчитать количество чисел оканчивающихся на 3.

2)В диапазоне от 0 до 50 подсчитать количество чисел сумма цифр которых равна 3.



Вы находитесь на странице вопроса "С клавиатуры вводятся оценки учащихся. Подсчитать количество сдавших экзамен (получили оценку не менее 3) и не сдавших предмет(получили 2).", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.