Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

написать программу на языке паскаль .ПЖЛ ПОМАГИТЕ дан одновременный массив из п целых чисел .составить программу вычисления суммы элементов стоящих на

10-11 класс

четных местах

Evgenia24 24 нояб. 2013 г., 6:50:43 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Elizavetalakom
24 нояб. 2013 г., 8:58:05 (10 лет назад)

var

  a : array [1..1000] of integer;

  i, n, sum : integer;

begin

  read (n);

  for i := 1 to n do read (a[i]);

  sum := 0;

  for i := 1 to n do

    if i mod 2 = 0 then inc (sum, a[i]);

  writeln (sum);

end.

+ 0 -
ЛилияМартынова
24 нояб. 2013 г., 9:29:26 (10 лет назад)

var

M:array[0..100]of integer;

i,k,n:integer;

begin

k:=0

randomize;

write('введите кол-во элементов массива');

read(n);

for i:=1 to n do

begin

M[i]:=random (30);

if i mod 2 =0 then k:=k+M[i]

else write ('Четных элементов нет');

writeln ('Сумма четных элементов', k);

end;

end.

Ответить

Другие вопросы из категории

Какой из перечисленных ниже признаков не является признаком новой компьютерной технологии?

1. обработка данных и получение результата

2. диалоговый режим работы с компьютером

3. интегрированность с другими программными продуктами

Читайте также

Пожалуста!!!!!!!!!!!!!!!!!!!!!!ОЧ срочно!!!!!! Написать программу на паскале, которая вводит

массив из N целых чисел и выводит на экран номера отрицательных элементов и сами эти элементы. Протестировать программу для следующих массивов:

а) 3 5 -2 0 -6 -8 1

б) -1 -2 -3 0 -1 2 3

массивы должны вводися вручную а не рандомно.

Написать программу, которая вводит с клавиатуры одномерный массив из n целых чисел, после чего выводит нулевые элементы с их индексами (их можно и не

оказаться)

нужно написать программу на c++
Используя обращения 1) по индексу и 2) по указателю.

написать программу на Assembler

добрый вечер, всем. помогите, пожалуйста, написать программу на Ассемблере.

задание:
Создать программу на языке Ассемблер, что позволяет организовать вычисления над элементами массивов

Объединить два массива 8-битных целых чисел со знаком. Сначала элементы второго затем первого.

заранее огромное спасибо всем!

3. Не используя функцию возведения в квадрат, напишите на языке Паскаль наиболее короткие алгоритмы вычисления а) y=x¹° б)y=x¹⁵ или а) y=x^10

б)y=x^15

Постараться использовать минимальное количество дополнительных переменных.

4. Запишите на языке Паскаль программу циклического обмена значениями трёх переменных a,b,c. Схема циклического обмена: a ← b ← c. Например, если до обмена было: a=1, b=2, c=3, то после обмена должно стать: a=2, b=3, c=1.

1)Вычислить значения функции y=4*x^3-2*x^2+5 для x, изменяющегося от -3 до 1 с шагом 0,1 на языке ПАСКАЛЬ!!СРОЧНОО ЗАВТРА ЭКЗАМЕН РЕБЯЯТКИ!

2)Найти количество всех нечетных чисел на интервале от 11 до 20
3)Найти сумму целых положительных четных чисел на интервале от 1 до 100
4)Найти сумму ряда,общий член которого равен А(х)=1/(3*N-2)*(3*N+1)
5)Дано произвольное число n≤100.Определить количество цифр в числе
ОЧЕНЬ НУЖНО!!НА ЯЗЫКЕ ПАСКАЛЬ!ВЫРУЧАЙТЕ!



Вы находитесь на странице вопроса "написать программу на языке паскаль .ПЖЛ ПОМАГИТЕ дан одновременный массив из п целых чисел .составить программу вычисления суммы элементов стоящих на", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.