Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Написать

10-11 класс

программу замены положительных элементов вещественного массива Y[1..N] на
0. (ПАСКАЛЬ-Массивы)


Alyaaayeah 19 сент. 2016 г., 5:55:31 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
HUkto123
19 сент. 2016 г., 7:29:31 (7 лет назад)

Решение в файле

uses crt;
var a: array of integer;    n, i: integer;    begin
WriteLn('Введите N');ReadLn(n);
a := new integer[n];
randomize; //заполняем массив случайными значениямиfor i:=0 to n-1 dobegina[i]:=random(100)-50;Write(a[i]:5);end;Writeln;
for i:=0 to n-1 do //заменяем положительные элементы нулемbeginif a[i]>0 then a[i]:=0;Write (a[i]:5);end;writeln;readln;end.

Ответить

Другие вопросы из категории

Напишите пожалуйста программу в Паскале

x^2 если sinx<0
-x если sin>= 0

Необходимо написать программу на Pascal, которая по указанному Вами году рождения определяет возраст человека.В том случае, если вычисленное

значение окажется меньше 18, то программа выводит на экран сообщение "Учиться" ;если вычисленное значение находится в интервале от 18 до 55, то программа выводит на экран сообщение "Работать" ;если вычисленное значение больше или равно 55, то программа выводит на экран сообщение "Отдыхать"

Читайте также

Написать подпрограмму, вычисляющую натуральную степень

числа. паскаль
написать программу на компьютере и проверить правильность
работы Вашей процедуры/функции, в этом случае в основной программе
должны быть реализованы ввод исходных данных и вызов
процедуры/функции.

Написать в Паскаль программу для решения следующей задачи.

Вводится строка, состоящая только из цифр без нуля. Написать пользовательскую функцию, которая возвращает строку , добавляя после каждого символа символ '0'.

написать программу на Assembler

добрый вечер, всем. помогите, пожалуйста, написать программу на Ассемблере.

задание:
Создать программу на языке Ассемблер, что позволяет организовать вычисления над элементами массивов

Объединить два массива 8-битных целых чисел со знаком. Сначала элементы второго затем первого.

заранее огромное спасибо всем!

Ребят, помогите! Тема: одномерные массивы. Две задачи:1) Написать прог

Ребят, помогите! Тема: одномерные массивы. Две задачи:

1) Написать программу, которая из заданного одномерного массива размерности N находит сумму только тех элементов, значения которых больше некоторого значения S.
S=5; Массив: 0,4 5,6 -2 10,1


2) При поступлении в ВУЗ абитуриенты, получившие "Двойку" на первом экзамене, ко второму не допускаются. В массиве A[N] записаны оценки экзаменующихся, полученных на первом экзамене. Подсчитать, сколько человек не допущено ко второму экзамену!

Заранее благодарю!



Вы находитесь на странице вопроса "Написать", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.