Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

1)Ввести 2 числа,заменить число суммой чисел,а большее произведением. 2)Ввести 2 числа А и В заменить первое нулем если оно меньше второго. 3)Журнал стоит

5-9 класс

k руб.Какую сдачу получит покупатель если у него в руб. 4)Определить ,является ли введенное шестизначное число счастливым,т.е. сумма первых трех цифр числа равна сумме последних трех цифр. 5)Определить ,является число А делителем числа В.

Timmon004 04 нояб. 2013 г., 12:00:21 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
кити99
04 нояб. 2013 г., 12:30:23 (10 лет назад)

1)

var

  a, b, c: real;

  IDE: boolean;

 

begin

  IDE:= false;

  writeln('Введите 2 числа');

  readln(a, b);

  c:= a;

  if (IDE = false) and (a < b) then 

  begin

    a:= a + b;

    b:= c * b;

    IDE:= true;

    writeln('a = ', a, ', b = ', b);

  end;

  if (IDE = false) and (b < a) then 

  begin

    a:= a * b;

    b:= a + b;

    IDE:= true;

    writeln('a = ', a, ', b = ', b);

  end;

  if (IDE = false) and (a = b) then

  begin

    writeln('Числа равны');

    IDE:= true;

  end;

end.

2)

var

  a, b: real;

 

begin

  writeln('Введите 2 числа');

  readln(a, b);

  if a < b then a:= 0;

  writeln('a = ', a, ', b = ', b);

end.

3)

var

  k, b: real;

 

begin

  writeln('Введите цену журнала');

  readln(k);

  writeln('Введите, сколько у покупателя денег');

  readln(b);

  if b > k then writeln('Покупатель получит ', b - k, ' р сдачи');

  if b = k then writeln('Покупатель не получит сдачи');

  if b < k then writeln('Покупателю придется доплатить ', k - b, ' р');

end.

4)

var

  a: 100000..999999;

  a1, a2, a3, a4, a5, a6: 1..9;

 

begin

  writeln('Введите шестизначное число');

  readln(a);

  a1:= a div 100000;

  a2:= (a mod 100000) div 10000;

  a3:= (a mod 10000) div 1000;

  a4:= (a mod 1000) div 100;

  a5:= (a mod 100) div 10;

  a6:= a mod 10;

  if (a1 + a2 + a3) = (a4 + a5 + a6) then writeln('Число является счастливым')

  else writeln('Число не является счастливым');

end.

5)

var

  a, b: integer;

 

begin

  writeln('Введите числа A и B');

  readln(a, b);

  if b mod a = 0 then writeln('Число ', a, ' является делителем числа ', b)

  else writeln('Число ', a, ' не является делителем числа ', b);

end.

Если все правильно, отметь решение как лучшее)

Если возникнут вопросы - задавай 

  

Ответить

Другие вопросы из категории

Книга занимает 300 страниц по 60 строк.В каждой строке заисанно по

55 символов.Вес одного символа равен 5 бит.В книге содержится 100
изображений по 280Кб.какое кол-во информации (в мб) занимает книга?

Кто понимает информатику ?

помогите

Читайте также

Напишите программу которая в последовательности натуральных чисел определяет сумму чисел, кратных 6. Программа получает на вход количество чисел в

последовательности, а затем сами числа. В последовательности всегда имеется число кратное 6. Кол-во чисел не превышает 100. Введённые числа не привышают 300. Программа должна ввести одно число - сумму чисел кратных 6

Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 5. Программа получает на вход количество чисел в

последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 5. Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести одно число – сумму чисел, кратных 5.

Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 3. Программа получает на вход количество чисел в

последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 3. Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести одно число – сумму чисел, кратных 3.

(Pascal)



Вы находитесь на странице вопроса "1)Ввести 2 числа,заменить число суммой чисел,а большее произведением. 2)Ввести 2 числа А и В заменить первое нулем если оно меньше второго. 3)Журнал стоит", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.