Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

даны 2 действительных числа.Меньше из них заменить полусуммой этих чисел,а большее-произведением этих чисел. прошу написать на русском языке

5-9 класс

Romeo00 05 дек. 2014 г., 14:43:01 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vikont777
05 дек. 2014 г., 17:31:13 (9 лет назад)

извини, но из языков программирования которые пишут на русском знаю только 1С и это как по мне издевательство

пишу на старом добром паскале

 

var a,b,min,max:real;

  read(a,b);

  if (a <b) then begin

    min:=a;

    max:=b;

    a:= (min+max)/2;

    b:=min*max;

 end

 else begin

    min:=b;

    max:=a;

    b:= (min+max)/2;

    a:=min*max;

 end;

 writeln(a,b);

End.

 

 

Ответить

Читайте также

Задачи по Паскалю.Условный оператор.

1.Даны два действительных числа меньшее из них замените полусуммой их, а большее их произведением.
2.Найдите решение уравнения ах+ в=0, если оно существует,если а=0
3.написать программу удвоения меньшего из двух чисел

помогите решить пожалуйстаа)

1)Дано целое число ,если оно не четное ,то увеличить его на 3,иначе увеличить его в 5 раз.
2)Даны 2 числа вещественного типа не равные друг другу.Меньшее из них заменить половиной их суммы ,а большее - их удвоенным произведением.
3)Даны 2 числа k и m.Если первое число отрицательно ,то его значение заменить его модулем;иначе второе число заменить единицей .Результат (оба числа) вывести на экран.



Вы находитесь на странице вопроса "даны 2 действительных числа.Меньше из них заменить полусуммой этих чисел,а большее-произведением этих чисел. прошу написать на русском языке", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.