Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Файл Date.in файл содержит 3 различных целых чисел, разделенных пробелами. Написать программу, которая укажет, какие из чисел является максимальным,

5-9 класс

минимальным и какие не является ни минимальным, ни максимальным. Результат отображается на экране и файле date.out.

Nadj200423 12 марта 2017 г., 10:09:58 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Annajensen
12 марта 2017 г., 11:09:52 (7 лет назад)

var
  a, b, c, min, max, mid: integer;
  f1, f2: Text;

begin
  Assign(f1, 'date.in');
  Reset(f1);
  Read(f1, a, b, c);
  Close(f1);
  if a > b then begin
    max := a; min := b
  end
  else begin
    max := b; min := a
  end;
  if max > c then begin
    if min < c then mid := c
    else begin
      mid := min; min := c
    end
  end
  else begin
    mid := max; max := c
  end;
  writeln('Меньшее=', min, ' среднее=', mid, ' большее=', max);
  Assign(f2, 'date.out');
  Rewrite(f2);
  Write(f2, min, ' ', mid, ' ', max);
  Close(f2)
end.

Ответить

Другие вопросы из категории

Читайте также

Решите пожалуйста.Сделаю лучшим ответом))

Дана последовательность целых чисел,заканчивающаяся нулем.Написать программу,которая выводит последнее ненулевое число последовательности.

1. Даны два различных вещественных числа X и Y. Написать программу, возведения наименьшего из чисел в квадрат, наибольшего – в куб и нахождения среднего

арифметического полученных значений.
2. За весну Обломов похудел на p1 кг, за лето поправился на p2 кг, за осень похудел на p3 кг, за зиму поправился на p4 кг. Написать программу, определяющую, похудел или поправился за год Обломов.
3. Написать программу, которая определяет, является ли целое число четным двузначным числом.
4. Даны коэффициенты квадратного уравнения. Написать программу, определяющую его корни

написать программу которая в последовательности натур. чисел определяет сумму всех чисел кратных 8 и оканчивающихся на 4.программа получает на вход

натур. числа а также их количество.количество чисел не превышает 1000.программа должна вывести одно число:сумму всех чисел кратных 8 и оканч. на 4
ПОМОГИТЕ, ПОЖАЛУЙСТАА



Вы находитесь на странице вопроса "Файл Date.in файл содержит 3 различных целых чисел, разделенных пробелами. Написать программу, которая укажет, какие из чисел является максимальным,", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.