Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Даны три действительных числа. Возвести в квадрат те из них > 5

10-11 класс

Mis123 18 апр. 2013 г., 18:34:02 (11 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Katalina79895
18 апр. 2013 г., 19:04:57 (11 лет назад)

var

 a,b,c:Extended;

begin

 Readln(a,b,c);

 if a>5 then a:=a*a;

 if b>5 then b:=b*b;

 if c>5 then c:=c*c;

 Writeln(a,' ',b,' ',c);

end.

+ 0 -
Nshablakova
18 апр. 2013 г., 20:52:13 (11 лет назад)

program abcd;
uses crt;
var a,b,c:real;
begin
writeln(Введите 3 действительных числа через пробел"');readln(a,b,c);
if a>5 then begin
a:=a*a;
writeln(a)
end
else writeln('Данное число не может быть возведено в квадрат, так как не соответствует условию "число >5"');
if b>5 then begin
b:=b*b;
writeln(b);
end
else writeln('Данное число не может быть возведено в квадрат, так как не соответствует условию "число >5"');
if c>5 then begin
c:=c*c;
writeln(c);
end
else writeln('Данное число не может быть возведено в квадрат, так как не соответствует условию "число >5"');
end.

 

Ответить

Другие вопросы из категории

паскаль

Найти все натуральные
решения уравнения:x^3+y^3=M . Где М>0 задает
пользователь. Использовать вложенные циклы.

Читайте также

Даны три действительных числа. Выбрать

из них те, которые принадлежат интервалу
(1, 3).

Помогите с задачками в паскале. Даны три положительных числа а, в, с. Проверить будут ли они сторонами треугольника. Если да то

вычислить площадь этого треугольника. Даны два действительных положительных числа х и у. Арифметические действия над числами пронумерованы (1 - сложение, 2 - вычитание, 3 - умножение, 4 - деление). Составить программу, которая по выведенному номеру выполняет то или иное действие над числами.



Вы находитесь на странице вопроса "Даны три действительных числа. Возвести в квадрат те из них > 5", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.