Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

дано 3 числа а,b,c.возвести в квадрат те числа которые отрицательные

5-9 класс

Egbugreev 05 янв. 2017 г., 20:30:54 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Mironicus
05 янв. 2017 г., 21:38:53 (7 лет назад)

uses crt;
var a,b,c:integer;
begin
writeln(' vvedite 3 chisla');
readln(a,b,c);
if a<0 then a:=sqr(a);
if b<0 then b:=sqr(b)
else
 if c<0 then c:=sqr(c);
writeln('a=',a);
writeln('b=',b);
writeln('c=',c);
end.

+ 0 -
Darishka142
05 янв. 2017 г., 22:53:40 (7 лет назад)

ПАСКАЛЬ !!!!

VAR
   a, b, c: Int64;
BEGIN
   Read(a, b, c);
   If (a < 0) then Writeln(a*a);
   If (b < 0) then Writeln(b*b);
   If (c <0 ) then Writeln(c*c);
END.

+ 0 -
Kalian1998
06 янв. 2017 г., 0:45:00 (7 лет назад)

что за язык?

Ответить

Другие вопросы из категории

Однажды бабушка попросила Машу помочь собрать ягоды крыжовника. Девочка взяла лукошко и подошла к большому колючему кусту. Она осторожно срывала ягоду

и опускала ее в лукошко. Так Маша делала до тех пор, пока на кусте не осталось ни одной ягоды. Из этих ягод сварили очень вкусное варенье. – выберите из предложенных надписей те действия, которые Маше придется повторять несколько раз. – какая надпись может служить условием? – в каком порядке нужно расставить надписи на блок-схеме? (перестановку надписей может произвести один из учащихся) – будет ли задача решена, если поменять местами «да» и «нет»? С помощью слайда 19 можно проверить правильность расстановки команд на схеме.

Читайте также

ПОМОГИТЕ ПОЖАЛУЙСТА С ДВУМЯ ЗАДАЧАМИ НА ЯЗЫКЕ PASCAL: 1)даны 2 числа, заменить второе число нулем, если оно не меньше первого и оставить его

прежним,если это не так. 2)Даны 3 числа, возвести в квадрат те из них, значения которых не отрицательны, а отрицательные оставить без изменений

даны два числа. Если первое число нечетное, то найти сумму кубов, а иначе - куб суммы. даны три числа. Если хотя бы одно из чи

сел - отрицательное, то найти Iа+ b+cI иначе а+b+c +d в корне.

Даны три числа. Если произведение данных чисел - отрицательное, то каждое число возвести в квадрат, иначе найти модуль каждого числа

ПОМОГИТЕ ОЧЕНЬ ПРОШУ

Помогите по программе paskal : 1.дано целое число.напишите программу которая уменьшает на 2 модуль этого числа и выводит на экран монитора

результат

2.дано целое число.напишите,программу которая выводит на экран последнюю цифру данного числа,затем возводит ее в квадрат и выводит на экран монитора результат

1)Определить, является ли числоа делителем числа b. Даны вещественные числа х и у, не равные друг другу. Меньшее из

этих двух чисел заменить половиной их суммы, а большее — их удвоенным произведением.

2)Даны вещественные числа х и у, не равные друг другу. Меньшее из этих двух чисел заменить половиной их суммы, а большее — их удвоенным произведением.

дано натуральное число N, Написать ему выводящую на экран последовательность натуральность натуральных чисел от 1 до N, задание 2 дано натуральное число

N, Написать ему выводящую на экран последовательность натуральность натуральных чисел отN до 1, номер 3 Даны натуральные числа N и К.Написать программу выводящую на экран последовательность из N чисел , каждое из которых равно К хотя бы что нибудь решите помогите очень надо!!!!!!!!!



Вы находитесь на странице вопроса "дано 3 числа а,b,c.возвести в квадрат те числа которые отрицательные", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.