Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Заданы координаты трех точек плоскости. Эти точки не лежат на одной прямой? Нужна программа в Паскале.

10-11 класс

белохвостик 04 февр. 2017 г., 3:48:57 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Katysha01
04 февр. 2017 г., 5:22:02 (7 лет назад)

var x1,x2,x3,y1,y2,y3:real;
begin
readln(x1,y1);
readln(x2,y2);
readln(x3,y3);
if (x3-x1)*(y2-y1)=(x2-x1)*(y3-y1) then writeln('lejat na pryamoi') else writeln('ne lejat na pryamoi');
end.

Ответить

Другие вопросы из категории

Помогите очень надо, пожалуйста!

в знаменателе после скобок квадрат

Задача, состав те программу в паскале! 1)Дано трехзначное число. Определить количество всех различных трехзначных чисел, которые можно составить из

цифр этого числа. 2) Даны три числа. Подсчитать количество четных чисел . Заранее спасибо !

Читайте также

В прямоугольной системе координат даны координаты A (3 3), B (-42 14) C (-2 4)

Найти координаты точки М, где М - середина ВС



Нужна программа в паскале, помогите пожалуйста.

Два игрока играют в игру. На координатной плоскости стоит фишка. Игроки ходят поочереди. В начале игры фишка находится в точке с координатами (4,2).

Ход состоит в том, что игрок перемещает фишку из точки с координатами (x,y) в одну из трех точек: или в точку с координатами (x+3,y), или в точку с координатами (x,y+3), или в точку с координатами (x,y+4). Выигрывает игрок, после хода которого расстояние по прямой от фишки до точки с координатами (0,0) не меньше 10 единиц. Кто выигрывает при безошибочной игре – первый или второй игрок? На каком шаге игры произойдет выигрыш? Каким должен быть первый ход выигрывающего игрока?

Составьте программу, определяющую, лежит ли точка с указанными координатами X, Y на окружности радиуса R с центром в начале координат.

Program Frankenstein;
var
x,y,r:integer;
Begin
Write('Введите координату X: ');
Readln(x);
Write('Введите координату Y: ');
Readln(y);
Write('Введите длину радиуса R: ');
Readln(r);
If (sqr(x)+sqr(y))=r
then writeln('Точка лежит на окружности!')
Else writeln('Точка не лежит на окружности!');
End.

Почему программа всегда показывает что точка не лежит на окружности, хотя на самом деле она лежит! Где я ошибся?



Вы находитесь на странице вопроса "Заданы координаты трех точек плоскости. Эти точки не лежат на одной прямой? Нужна программа в Паскале.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.