Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

На координатной плоскости своими действительными координатами (x1, y1), (x2, y2), (x3, y3), (x4, y4) задан выпуклый четырехугольник. Проверить, является

10-11 класс

ли он параллелограммом, если ДА – вычислите выражение |(a+b)2+| с точностью до сотых, где а и b смежные стороны параллелограмма.

Kseni200 10 апр. 2015 г., 14:10:45 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Marina200118
10 апр. 2015 г., 15:15:08 (9 лет назад)

Type Point=record
   x: integer;
   y: integer;
end;
var p1, p2, p3, p4 : Point;
function length(p1, p2 : Point) : real;
begin
  length := sqrt(sqr(p1.x - p2.x) + sqr(p1.y - p2.y));
end;
Begin
  readln(p1.x, p1.y);
  readln(p2.x, p2.y);
  readln(p3.x, p3.y);
  readln(p4.x, p4.y);

  if (length(p1, p2) = length (p3, p4)) and (length(p3, p2) = length (p1, p4)) then
    writeln('P = ', abs(2 * (length(p1, p2) + length(p3, p2)) ))
  else writeln('No');
End.

Ответить

Другие вопросы из категории

помогите срочно))

что сможете))
нужно решить в течении получаса_))

помогите создать таблицу в html
ПОМОГИТЕ СРОЧНО ПЖЛСТ!!!

Автоматизированная система управления кадрами предприятия хранит личные дела работников в следующем формате: каждое личное дело
содержит 12 страниц, по 36 строк на каждой странице, по 64 символа в каждой строке, каждый символ кодируется одним байтом. Определите количество личных дел, хранимых в автоматизированной системе, если известно, что все данные занимают в памяти компьютера 13,5 мегабайта.

Читайте также

Помогите составить программу, пожалуйста, нужно очень срочно! Пятиугольник ABCDE задан координатами своих вершин

(X1,Y1)(X2,Y2)(X3,Y3)(X4,Y4)(X5,Y5) соответственно. Найти площадь этого пятиугольника используя в качестве подпрограммы a) функцию

написать программу на паскале Треугольник задан координатами (x1, y1), (x2, y2), (x3, y3)

своих вершин. Вычислить радиус окружности, вписанной в треугольник

3. Даны два неравных числа X и Y. Большее из них заменить на сумму этих чисел, а меньшее увеличить в три раза.

4. Известны периметр первого треугольника Р1, координаты вершин второго x1, y1, x2, y2,x3, y3 и длины сторон третьего – а3, в3, с3. Найти и вывести на экран периметр меньшего треугольника.

Алгоритмы ветвления

Помогите надо написать программу в паскале. 1)координаты двух различных полей шахматной доски x1, y1,x2, y2 (целые числа, лежащие в диапазоне 1–8).

Проверить истинность высказывания: «Ладья за один ход может перейти с одного поля на другое». 2) Дано трехзначное число. Проверить истинность высказывания: «Все цифры данного числа различны». 3)Даны две переменные целого типа: A и B. Если их значения не равны, то присвоить каждой переменной сумму этих значений, а если равны, то присвоить переменным нулевые значения. Вывести новые значения переменных A и B.



Вы находитесь на странице вопроса "На координатной плоскости своими действительными координатами (x1, y1), (x2, y2), (x3, y3), (x4, y4) задан выпуклый четырехугольник. Проверить, является", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.