Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Паскаль:

10-11 класс

1) дана строка символов, в которой есть хотя бы вхождение 'abc'. Все вхождения 'abc' заменить на 'def'

2) в заданном тексте все встретившееся буквы 'a' удалить, а буквы 'd' удвоить

Ykoteika 20 апр. 2015 г., 17:07:45 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Oks160574
20 апр. 2015 г., 18:58:37 (9 лет назад)

1. var s:string;
i:integer;
begin
readln(s);
for i:=1 to length (s)-3 do
if (s[i]='a') and (s[i+1]='b') and (s[i+2]='c') then begin
 s[i]:='d';
 s[i+1]:='e';
 s[i+2]:='f';
 end;
writeln (s);
readln;
end.



2. var s:string;
i:integer;
begin
readln(s);
for i:=1 to length (s) do
if s[i]='a' then s[i]:='d';
writeln (s);
readln;
end.




Ответить

Другие вопросы из категории

Написать программу вычисления площади кольца. Ниже приведен рекомендуемый вид экрана во время выполнения программы.

Вычисление площади кольца
Введите исходные данные:
Радиус внешнего круга (см):
Радиус внутреннего круга (см):

Площадь внешнего круга:
Площадь внутреннего круга:
Площадь кольца:

Читайте также

Рассказать и показать на примере Паскаль: 1) Что такое absolute и для чего нужна? 2) Что такое asm и для чего нужна? 3) Что такое

constructor и destructor и для чего нужна?

4) Что такое implementation и для чего нужна?

5) Назовите модули Паскаль ( в строке Uses, например crt) и какие возможности этот модуль дает?

6) Что за тип переменной: указательный (Pointer)

7) И на последок: что означает символ @ , #, $ , ^

3. Не используя функцию возведения в квадрат, напишите на языке Паскаль наиболее короткие алгоритмы вычисления а) y=x¹° б)y=x¹⁵ или а) y=x^10

б)y=x^15

Постараться использовать минимальное количество дополнительных переменных.

4. Запишите на языке Паскаль программу циклического обмена значениями трёх переменных a,b,c. Схема циклического обмена: a ← b ← c. Например, если до обмена было: a=1, b=2, c=3, то после обмена должно стать: a=2, b=3, c=1.

ПАСКАЛЬ!

как на языке паскаль записать
корень5x - корень4y +1
??

Прошу переделать код программы с языка Паскаль на С++.

Вот код Паскаль:
var
f:array[1..500] of record
fam:string;
bal:boolean;
end;
buf:boolean;
str:string;



Вы находитесь на странице вопроса "Паскаль:", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.