Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

задайте массив из 10 элементов с помощью датчика случайных чисел. выведите на экран исходный массив и и номера тех элементов,которые расположены между

5-9 класс

наибольшим и наименьшим элементами

Happ 05 сент. 2013 г., 16:09:51 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Valeriyaluckay
05 сент. 2013 г., 18:14:17 (10 лет назад)

лагает(( но отметь это как ответ)

+ 0 -
этомы
05 сент. 2013 г., 21:07:02 (10 лет назад)

Уже отвечал, но все же такое решение актуальнее: 

var 
ar:array[1..10] of integer;
max,min,i,kmax,kmin:integer;
begin
randomize;

max:=0;
min:=1000;

for i:=1 to 10 do begin  

+ 0 -
Almazka00
05 сент. 2013 г., 21:40:02 (10 лет назад)

program lentai;
var a:array[1..10] of integer;
max,min,i:integer;
begin
cls;
write('Массив:');
for i:=1 to 10 do
begin
a[i]:=random(50);//числа от 0 до 49
write(' ',a[i]) //вывели изначальный массив
end;
writeln();
min:=1;//нечто большое
max:=1;//нечто маленькое
for i:=1 to 10 do

+ 0 -
ШоколаднаяКоролева
05 сент. 2013 г., 22:36:22 (10 лет назад)

begin
if a[i]<a[min] then min:=i;
if a[i]>a[max] then max:=i;
end;
writeln('Номер наименьшего элемента массива: ',min);
writeln('Номер наибольшего элемента массива: ',max);
if min-max>2 then
begin
write('Числа между ними:');
for i:=max+1 to min-1 do write(' ',a[i]);
end

+ 0 -
Extazyjk
06 сент. 2013 г., 0:35:11 (10 лет назад)

else
if max-min>2 then
begin
write('Числа между ними:');
for i:=min+1 to max-1 do write(' ',a[i]);
end
else write('Чисел между ними нет:');
end.

+ 0 -
Норисса
06 сент. 2013 г., 1:53:08 (10 лет назад)

вот так в общем, окно ответа лагает(

+ 0 -
Krsmch
06 сент. 2013 г., 3:19:52 (10 лет назад)

блин)) спаСибо огромное)

Ответить

Другие вопросы из категории

срочно нужно!!!№1задание с выборочным ответом.КАкое количество информации содержит один разряд двоичного числа? 1)1 байт 2)3 бита 3)4 бита 4)1 бит.

№2.Задание с кратким ответом. Какое количетсво информации несет двоичный код 10101010?

Помогите срочно!!

1. Скорость чтения ученика 6 класса составляет приблизительно 160 символов в минуту.
Какой объём информации получит ученик, если он будет непрерывно читать в течении 30 минут?
2. Сколько времени потребуется ученику, чтобы прочесть текстовый файл, занимающий половину трёхдюёмовой дискеты?

. Для

чего используются ярлыки объектов?

Что обеспечивает самый оперативный доступ к информации о дате рождения человека?

А)Свидетельство о рождении
Б)Информация в записной книжке
В)Интернет
Г)Память этого человека

ПОЖАЛУЙСТА ПОМОГИТЕ!

1) В книге 35 стр. На каждой стр. 40 строк по 30 символов в строке. Вычислите информационный объем книги.
2) Инфор. объем сообщения 8 Мегабайт. Сколько символов содержит это сообщение?
3) Объем инфор. сообщения составляет 65536 бита. Выразите в килобайтах.

Читайте также

сформулируйте массив,содержащий 15 элементов,с помощью датчика случайных чисел. получите новый массив,каждый элемент которого равен обратному

соответствующему элементу исходного массива. посчитайте кол- во неизменившихся эелементов и найдите в новом массиве максимальный о абсолютной величине отрицательный элемент. выведите на экран исходные и полученные результаты (ПОМОГИТЕ ПОЖЛСТ ОЧЕНЬ НАДО)

Сформируйте массив, содержащий 15 элементов, с помощью датчика случайных чисел. Получите новый массив, каждый элемент которого равен произведению

соответствующего элемента исходного массива и заданного с клавиатуры числа А. В проученном массиве найдите максимальный элемент среди элементов с нечетными номерами. Выведите на экран исходные полученные результаты.

1 Задание:сформируйте и выведите на экран массив из девяти элементов,каждые три последовательных элемента которого составлены по следующему правилу:

1-й равен значению текущего индекса, увеличенному на 3; 2-й равен квадрату предыдущего индекса; 3-й равен сумме двух предыдущих элементов. 2 Задание : сформируйте массив, содержащий 15 элементов ,с помощью датчику случайных чисел. Получите новый массив,каждый элемент которого равен сумме соответствующего элемента исходного массива и его индекса. В полученном массиве удвойте элементы,которые меньше заданного с клавиатуры числа А,и найдите их сумму . Выведите на экран исходные и полученные результаты .

Сформируйте массив, содержащий 15 элементов с помощью датчика случаных чисел; получите новый массив, каждый элемент которого равен разности

квадрата и самого соответствующего элемента исходного массива. найдите резность сумм элементов исходного и нового массива. Выведите на экран исходный и поулченные результаты.

Спасибо заранее



Вы находитесь на странице вопроса "задайте массив из 10 элементов с помощью датчика случайных чисел. выведите на экран исходный массив и и номера тех элементов,которые расположены между", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.