Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Задача в Pascal ABC. Задайте массив из 10 элементов с помощью датчика случайных чисел. Замените элементы массива, которые больше введенного с клавиатуры

5-9 класс

числа N. Выведите на экран исходный и полученный массив. Пожалуйста

Rxxxt 26 дек. 2014 г., 4:57:40 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
аминочка0808
26 дек. 2014 г., 6:53:52 (9 лет назад)

var mas:array[1..10] of integer; i:integer;beginrandomize;for i:=1 to 10 dobeginmas[i]:=random(200)-100;write (mas[i]:4);end;writeln;for i:=1 to 10 dobeginif (mas[i]<0) then mas[i]:=1;write (mas[i]:4);end;writeln; end.

+ 0 -
Almira0677
26 дек. 2014 г., 9:33:07 (9 лет назад)

program gt;
const h=10;
var i,n:integer;
a:array[1..1000]of integer;
begin
readln(n);
randomize;
for i:=1 to h do
begin
a[i]:=random(100);
write(a[i]:2,' ');
if(a[i]>n)then a[i]:=0;
end;
writeln;
for i:=1 to h do
write(a[i]:2,' ');
end.

+ 0 -
Dmitrrr
26 дек. 2014 г., 11:07:19 (9 лет назад)

ок

+ 0 -
Zyf1234
26 дек. 2014 г., 13:43:25 (9 лет назад)

на что заменять?

+ 0 -
Bigsteak
26 дек. 2014 г., 15:02:07 (9 лет назад)

заменю на 0

Ответить

Другие вопросы из категории

Решенить задачу по паскаль

1.дано число х вычислите қол квадрат
2.имеется число а , число b в 2 раза больше, определить их сумму, числа целые. Срочно

QBASIC

Задана матриця K(N,L) Знайти кількість відємних, кратних трьом елементів.
Заданная матрица K (N, L) Найти количество отрицательных, кратных трем элементов.

Составьте программу которая выводит на экран значение выражения а=в7

В в седьмой степани.
Program...
var...
begin
......
end.
Плиз хелпт!!!

Читайте также

1 Задание:сформируйте и выведите на экран массив из девяти элементов,каждые три последовательных элемента которого составлены по следующему правилу:

1-й равен значению текущего индекса, увеличенному на 3; 2-й равен квадрату предыдущего индекса; 3-й равен сумме двух предыдущих элементов. 2 Задание : сформируйте массив, содержащий 15 элементов ,с помощью датчику случайных чисел. Получите новый массив,каждый элемент которого равен сумме соответствующего элемента исходного массива и его индекса. В полученном массиве удвойте элементы,которые меньше заданного с клавиатуры числа А,и найдите их сумму . Выведите на экран исходные и полученные результаты .

решить через паскаль через массивы)) 1.Дан одномерный массив из 10 элементов. Заменить все большие 7 члены массива числом 7. Найти количество

таких членов.

2.Дан массив из 10 элементов. Найти количество элементов с четными индексами.

3.Дан массив из 10 элементов. Найти наибольший элемент массива.

(Pascal) Задача:

Дан массив из 8 элементов, с помощью датчика случайных чисел посчитать количество нечётных элементов.

сформулируйте массив,содержащий 15 элементов,с помощью датчика случайных чисел. получите новый массив,каждый элемент которого равен обратному

соответствующему элементу исходного массива. посчитайте кол- во неизменившихся эелементов и найдите в новом массиве максимальный о абсолютной величине отрицательный элемент. выведите на экран исходные и полученные результаты (ПОМОГИТЕ ПОЖЛСТ ОЧЕНЬ НАДО)



Вы находитесь на странице вопроса "Задача в Pascal ABC. Задайте массив из 10 элементов с помощью датчика случайных чисел. Замените элементы массива, которые больше введенного с клавиатуры", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.