Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Вычислить прямой, обратный и дополнительный коды и выполнить действие в обратном коде для указанных чисел в двоичной системе счисления: 113-36

10-11 класс

Lilu45 24 июня 2014 г., 22:46:58 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Kyko
25 июня 2014 г., 0:27:53 (9 лет назад)

Число 113: для него прямой, обратный и дополнительный коды совпадают, так как оно положительное.

113(10)=01110001

Ответить

Другие вопросы из категории

Почему на этапе ввода последней ступени (т.е. задали х=5 и вводим 5 ступень) паскаль выкидывает ошибку: "Индекс находился вне границ массива", ведь al[x]

это его последний элемент, разве нет?
Код:

program s1;
var x, i:integer;
al, tl: array of real;
begin
writeln ('Введите количество ступеней ракеты'); read (x);
setlength (al, x);
setlength (tl, x);
for i:=1 to x do begin
writeln ('Введите ускорение ', i, ' ступени'); read (al[i]);
writeln ('Введите время работы ', i, ' ступени'); read (tl[i]);
end;
end.
P.S.: Переписать массив в статический не предлагать, нужен именно переменной длины. Заранее спасибо.

751 перевести в римскую систему
Запись

некоторого натурального числа X в шестнадцатеричной системе счисления имеет
ровно три значащих разряда. Это число увеличили в два раза, и оказалось, что
запись получившегося числа Y в шестнадцатеричной системе также имеет ровно три
значащих разряда, причем сумма цифр шестнадцатеричной записи исходного числа X
равна сумме цифр шестнадцатеричной записи полученного числа Y. Сколько
существует таких чисел X, которые удовлетворяют указанным условиям и при этом
содержат хотя бы одну цифру 2 в своей шестнадцатеричной записи? В ответе
укажите целое число.
Нужно составить программу, которая автоматически переберет все числа от 100 до FFF

Читайте также

помогите срочно

Дано a=B3(16);.b=74(8) Выполнить действие a*b ответ представить в 2-й системе счисления.

В чем преимущество кода Бодо по сравнению с кодом Морзе?

В чем преимущество кода Морзе по сравнению с кодом Бодо?

20,9- Перевести их в 2-ую, 8-ую и 16-ую, системы счисления. Выполнить в этих системах их сложение, вычитание и умножение. Ответ записать в 10-ой

системе счисления.

80,1- Перевести их в 2-ую, 8-ую и 16-ую, системы счисления.

Выполнить в этих системах их сложение, вычитание и умножение.

Ответ записать в 10-ой системе счисления.



Вы находитесь на странице вопроса "Вычислить прямой, обратный и дополнительный коды и выполнить действие в обратном коде для указанных чисел в двоичной системе счисления: 113-36", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.