Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

написать программу на языке С#:. Последовательность

10-11 класс

целых ненулевых чисел вводится с клавиатуры. Окончанием последовательность
является 0. Определите

произведение чисел, которые делятся на 5

Daryak12000 29 июня 2014 г., 3:17:25 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Annanepran
29 июня 2014 г., 3:54:14 (9 лет назад)

using System;


namespace ConsoleApp {
    internal class Program {
        private static void Main() {
            var product = 1;
            int n;
            do {
                Console.WriteLine("Введите число");
                n = Convert.ToInt32(Console.ReadLine());
                if (n != 0 && n % 5 == 0) {
                    product *= n;
                }
            } while (n != 0);
           
            Console.WriteLine("Product = " + product);

            Console.ReadKey();
        }
    }
}

Ответить

Другие вопросы из категории

Помогите составить программу

В зависимости от того введена ли открытая скобка или закрытая, напечатать "открытая круглая скобка" или "закрытая фигурная скобка".(учитывать круглые , квадратные,фигурные скобки)

Почему на этапе ввода последней ступени (т.е. задали х=5 и вводим 5 ступень) паскаль выкидывает ошибку: "Индекс находился вне границ массива", ведь al[x]

это его последний элемент, разве нет?
Код:

program s1;
var x, i:integer;
al, tl: array of real;
begin
writeln ('Введите количество ступеней ракеты'); read (x);
setlength (al, x);
setlength (tl, x);
for i:=1 to x do begin
writeln ('Введите ускорение ', i, ' ступени'); read (al[i]);
writeln ('Введите время работы ', i, ' ступени'); read (tl[i]);
end;
end.
P.S.: Переписать массив в статический не предлагать, нужен именно переменной длины. Заранее спасибо.

Читайте также

написать программу на Assembler

добрый вечер, всем. помогите, пожалуйста, написать программу на Ассемблере.

задание:
Создать программу на языке Ассемблер, что позволяет организовать вычисления над элементами массивов

Объединить два массива 8-битных целых чисел со знаком. Сначала элементы второго затем первого.

заранее огромное спасибо всем!

1) Напишите пожалуйста программу (на языке BASIC) вычисления по длинам двух сторон треугольника и углу между ними длины третьей стороны и двух других

углов.
2)
Напишите пожалуйста программу (на языке BASIC) для определения подобия:
а) двух прямоугольников по двум смежным сторонам;
б) двух треугольников по трем сторонам.

Написать программы на языке С++

1) С клавиатуры вводится 2 числа - целое и вещественное. Программа выводит их сумму на экран.
2) Написать процедуру, которая умножает число типа int на число типа float на число типа double и выводит результат на экран
3) Написать процедуру, которая будет выводить любой текст, являющийся ее аргументом
4) С клавиатуры вводится 5 символов поочередно, программа выводит на экран акроним к слову которая образует эти 5 символов

Написать программу на языке Паскаль для вычисления значений функции y (см. для своего варианта) на интервале [a,b] с шагом h. Значения a,b и h ввести с

клавиатуры. На экран вывести результат вычислений в виде таблицы. 1 Блок-схема алгоритма программы, выполненная с использованием графических средств редактора WORD; 2 Текст программы; 3 Результаты выполнения (копия экрана). (3x+2)^2- sqrt3x/(3x)^2 a 5;b 7; h 0,1

программа на C++ в визуальном режиме (есть несколько вариантов кода программы)

доброй ночи, уважаемые программисты и успевающие в учебе студенты. помогите, пожалуйста, написать программу на C++ (в визуальной вкладке).

ВОТ ЗАДАНИЕ:
дано три переменные вещественного типа. если их значения упорядочены по возрастанию или убыванию, то удвоить их; иначе заменить значение каждой переменной на противоположное. вывести значения переменных.


я прикрепила несколько тестовых файлов (блокнот) в которых есть несколько вариантов решение этого задание (то есть коды программ), а вы скажите какой из них лучше всего подходит, а также скажите какие компоненты нужно кинуть на форму-дизайн (то есть какие кнопки, и что на них писать). в этих 3 файлов есть написанный код программы, нужно написать: на какие кнопки что писать и какой вариант решение больше подходит.

заранее огромное спасибо всем за помощь!!!



Вы находитесь на странице вопроса "написать программу на языке С#:. Последовательность", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.