Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Даны три произвольных числа a,b,c, значение которых задают длины сторон треугольника. Выведите 0,если нельзя построить треугольник с такими длинами

5-9 класс

сторон; 3,если получается равностороний треугольник; 2 равнобедренный; 1 в остальных случаях. Задача в Паскале!!!

Povarnicina83 26 сент. 2014 г., 6:14:16 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Katy19971
26 сент. 2014 г., 8:49:28 (9 лет назад)

program t3;

var a,b,c:real;     {допустимо поменять на integer}

begin

writeln ('Vvedit a,b,c');

readln (a,b,c); 

if (a<=b+c) and (b<=a+c) and (c<=a+b) then writeln ('0'); else

if (a=c) and (c=b) then writeln (3);  else

if (a=c) or (a=b) or (b=c) then writeln ('2'); else

writeln ('1');

readln

end. 

 

Ответить

Другие вопросы из категории

Срочно!! Составить программу в паскаль.

Задан массив A(n) и число х, написать программу, которая печатает "да", если х совпадает с одним из элементов A, и "нет" в противном случае.

Читайте также

даны два числа. Если первое число нечетное, то найти сумму кубов, а иначе - куб суммы. даны три числа. Если хотя бы одно из чи

сел - отрицательное, то найти Iа+ b+cI иначе а+b+c +d в корне.

Даны три числа. Если произведение данных чисел - отрицательное, то каждое число возвести в квадрат, иначе найти модуль каждого числа

ПОМОГИТЕ ОЧЕНЬ ПРОШУ

1.Дано трехзначное число. а)Определите, входят ли в него цифры 4 и 7. б)Определите, входят ли в него одновременно цифры 4 и 7. 2. Даны

четыре целых числа. Вывести на экран минимальное из них.

3.Даны три вещественных числа a, b и с - коэффициенты уравнения ax^2+bx+c. Найдите решение этого уравнения или сообщите, что решения не существует.

Даны три натуральных числа. Напишите программу, определяющую, существует ли треугольник с такими длинами сторон. Если существует, определите его тип

Имеются данные о количестве полных лет трех призеров спартакиады. Напишите программу, выбирающую и выводящую возраст самого младшего призера.



Вы находитесь на странице вопроса "Даны три произвольных числа a,b,c, значение которых задают длины сторон треугольника. Выведите 0,если нельзя построить треугольник с такими длинами", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.