Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

ввести с клавиатуры число a.вывести значение переменной r. в случае невозможности произвести вычесление,вывести сообщение для изменения значения

5-9 класс

переменной a.
r = корень 2a . это программа из ткрбо паскаль. напишите ее плиз

милочкалз 16 дек. 2016 г., 16:49:17 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Chokolevsky
16 дек. 2016 г., 18:30:43 (7 лет назад)

var a,r: real;  
begin 
repeat 
Write ('Введите значение a = '); 
Readln (a);
until a>0;
r:=sqrt(2*a);
writeln('r = ' ,r); 
end.

Ответить

Другие вопросы из категории

Не получается записать правильно. Помогите, пожалуйста

Я думаю, что сначала переменную нужно div 10, после чего результат mod 10. А дальше сравнить. Как это написать?

Решите хоть что нибудь 34 балла!!!

дан массив из n элементов и целые числа x и y
найти номера тех, которые принадлежат отрезку X Y
2.Да н массив из n элементов Определить самый большой элемент массива стоящий на чётном месте заведомо известно что все элементы неотрицательны и не превышают 1000
3. дано натурадльное число сформировать масив n n - 1 n-2 ... 2 1
4. дан массив из n элементов . увеличить все положительные элементы на их величину номера

Читайте также

Задание1. Значение переменной Х ввести с клавиатуры. Переменной У присвоить значение 5. Вывести на экран информацию «знач.Х»+5=

«итог. сумма».

Задание 2.

Переменной Х присвоить значение 7. Переменной Р присвоить значение, равное квадрату Х. Вывести значения переменных Х и Р (через запятую). Значение Х увеличить на Х. Переменной Р присвоить значение, равное корню квадратному из Х. Вывести значения переменных Х и Р (через запятую).

DIKTANT 2

Задание 1.

Значение переменной Х присвоить в программе. При неотрицательном значении Х переменной У присвоить значение, равное корню квадратному из Х. В противном случае, переменной У присвоить значение, равное квадрату Х. Вывести на экран значение Х и значение У.

Задание 2.

Двум произвольным переменным присвоить произвольным образом соответственно 2 числа. Двум другим переменным присвоить значения, равные тангенсам двух предыдущих переменных. Вывести на экран значения всех переменных, а так же сумму значений двух последних переменных. помогите сделать пож

Подробности от учителя:1.Определить значение переменной у после выполнения следующего фрагмента программы:

y:=1;
For i:=2 to 4 do y:=y+i;

2.Определить значение переменной у после выполнения следующего фрагмента программы:
y:=0;
For i:=-100 to 100 do
If i mod 10 =5 then y:=y+i;

3. На промежутке [a;b] (a,b -целые числа, которые вводятся с клавиатуры) определить среднее арифметическое чисел кратных 7

Запишите значения переменной b после выполнения фрагмента алгоритма.

В ответе укажите одно число-значение переменной b

Задача1Введите числа в переменные a, b и c и напишите программу, которая меняет местами значения переменных по следующей

схеме, чтобы в переменной а оказалось первоначальное значение переменной с, в переменной b – значение а, в переменной с – значение b.(Пояснение: Используйте оператор присваивания и одну дополнительную переменную)



Вы находитесь на странице вопроса "ввести с клавиатуры число a.вывести значение переменной r. в случае невозможности произвести вычесление,вывести сообщение для изменения значения", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.