Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Три числа. Дан массив из целых N чисел а1, а2, .....аn. Нужно проверить, есть ли в этом массиве три числа сумма которых равна нулю.

10-11 класс

Kirilll8 10 июля 2013 г., 15:44:11 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
11вероника11
10 июля 2013 г., 17:39:46 (10 лет назад)

for i=1 to n do
 for j=1 to n do
   for k=1 to n do
     begin
      if ((i<>j) and (j<>k)) then sum=a[i]+a[j]+a[k];
      if(sum=0) then куданибудь выводиш числа a[i], a[j] a[k]
    end;

Ответить

Другие вопросы из категории

Что нужно дописать в коде на паскале для того чтобы программа выдавала сразу все возможные варианты(их 8)

var
A,B,C:boolean;
begin
for A:=false to true do begin
for B:=false to true do begin
for C:=false to true do begin
writeln ('1 zn'#9#9#9,'2 zn'#9#9#9,'A'#9,'B',#9,'C'#9);
writeln('(A and B) and C'#9#9,'A and (B and C)'#9#9,'A=',A,' ','B=',B,' ','C=',C);
if ((A AND B) AND C = A AND (B AND C)) then
readln;
end;
end;
end;
end.

В паскалеABC. Задание на картинке.
С клавиатуры задается цена 1 кг сыра. Вывести на экран цену 300г, 400г, 1200 сыра.

Написать программу, паскаль

Читайте также

№1. Дан массив из 30-ти элементов. Каждый элемент может принимать целочисленные значения от 0 до 100. Напишите программу, которая позволит найти сумму

двузначных элементов массива, которые не оканчиваются на 3. №2. Дан массив из 100 элементов. Каждый элемент может принимать целочисленные значения от 1 до 500. Напишите программу, которая позволит найти и вывести минимальное значение среди элементов массива, которые делят максимальное значение элементов массива без остатка.

№1. Дан массив из 30-ти элементов. Каждый элемент может принимать целочисленные значения от -100 до 100. Напишите программу, которая позволит

подсчитать среднее арифметическое положительных элементов массива, которые кратны первому элементу массива. №2. Дан массив из 40 элементов. Каждый элемент может принимать целочисленные значения от 0 до 200. Напишите программу, которая позволит найти наиболее часто встречающийся элемент массива

Дан массив из N

целых чисел а1, а2, ...,

1)дан одномерный массив из 5 элементов.найти сумму положительных элементов. 2)Дан одномерный массив из 7

элементов.Найти колличество четных положительных элементов.

3)Дан массив из 6 элементов.Найти произвдение положительных из них.



Вы находитесь на странице вопроса "Три числа. Дан массив из целых N чисел а1, а2, .....аn. Нужно проверить, есть ли в этом массиве три числа сумма которых равна нулю.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.