Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Витя работает недалеко от одной из станций кольцевой линии Московского метро, а живет рядом с другой станцией той же линии. Требуется выяснить, мимо

5-9 класс

какого наименьшего количества промежуточных станций необходимо проехать Вите по кольцу, чтобы добраться с работы домой.
Формат входных данных
Станции пронумерованы подряд натуральными числами 1, 2, 3, …, N (1-я станция – соседняя с N-й), N не превосходит 100.
Вводятся три числа: сначала N – общее количество станций кольцевой линии, а затем i и j – номера станции, на которой Витя садится, и станции, на которой он должен выйти. Числа i и j не совпадают. Все числа разделены пробелом.
Формат выходных данных
Требуется выдать минимальное количество промежуточных станций (не считая станции посадки и высадки), которые необходимо проехать Вите.
Примеры
Входные данные

Выходные данные

Комментарий

100 5 6

0

На кольцевой линии 100 станций; проехать с 5-й на 6-ю станцию Витя может напрямую, без промежуточных станций

10 1 9

1

На кольцевой линии 10 станций; проехать с 1-й на 9-ю станцию Витя может через одну промежуточную, ее номер 10

Npanowytrtn1998 15 мая 2014 г., 13:29:03 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Jokerdzzz
15 мая 2014 г., 14:59:03 (10 лет назад)

var  n,i,j,x,y1,y2:integer;
begin
readln(n,i,j);
x:=i;
y1:=-1;
y2:=-1;
//y1 - движение в прямом направлении
repeat
  x:=x+1;
  if x>n then x:=1;
  y1:=y1+1;
  until x=j;
//y2 - движение в обратном направлении
x:=i;
repeat
  x:=x-1;
  if x<1 then x:=n;
  y2:=y2+1;
  until x=j;  
if y2<y1 then writeln(y2) else writeln(y1);
end.

Ответить

Другие вопросы из категории

1. Текстовый редактор представляет собой программный продукт, входящий в состав____________

2. Операционные системы представляют собой программные продукты, входящие в состав_____________
3. Программы обслуживания устройств компьютера называются_____________
4. Прикладные программы- это программы для_________________

1. Операционная система — это___________________
2. Программы обслуживания устройств компьютера называются____________________
3. Программой архиватором называют программу, которая_______________
4. В прикладное ПО входят________________________

Укажите истинные высказывания(отметьте галочкой)

1)Человек разрабатывает алгоритм
Человек управляет работой других исполнителей по выполнению алгоритмов
Человек исполняем алгоритмы
2)Компьютер разрабатывает алгоритмы
Компьютер управляет работой связанных с ним технических устройств по выполнению алгоритмов
Компьютер сам выполняет алгоритмы(программы)
3)Исполнитель разрабатывает алгоритмы
Исполнитель управляет работой связанных с ним технических устройств по выполнению алгоритмов
Исполнитель чётко и безошибочно выполняет алгоритмы, составленные из команд , входящих в его СКИ 6 класс, электронная тетрадь Босова

помогите! я ничего не понимаю! составьте программу! Арифметические действия над числами пронумерованы так: 1 – сложение, 2 – вычитание, 3 – умножение, 4 –

деление. Дан номер действия n и вещественные числа a, b (b<>0). Выполнить над числами указанное действие и вывести результат. Например, n=2, а=0,40, в=1,00. Результат: а-в=-0,60. Единицы длины пронумерованы так: 1 – дециметр, 2 – километр, 3 – метр, 4 – миллиметр, 5 – сантиметр. Дан номер единицы длины и длина отрезка в этих единицах (вещественное число). Найти длину отрезка в метрах.

Який перший обчислюваний прилад

Читайте также

Четыре друга, Николай, Борис, Дмитрий и Максим живут в одном дворе. Одному из них 12 лет, другому 14, третьему 16, самому старшему 19. Они все увлекаются

программированием, но каждый из них специализируется только на каком-то одном из языков программирования: Бейсик, Паскаль, Си, Хаскел. Определите имя и любимый язык программирования 14-ти летнего программиста, если известно, что:Возраст Димы отличается от возраста любителя Си не более чем на 2 года.Специалист по Хаскелу старше любителя Си.Не менее чем один из приятелей родился между годом рождения Бориса и годом рождения Димы.Юноша, пишущий на Бейсике либо самый старший из друзей, либо самый младший.Коля не пишет на Бейсике и его возраст больше чем на 2 года отличается от возраста любителя Бейсика.Любитель Бейсика родился с разницей в 2 года со специалистом по Паскалю.Борис старше программиста на Паскале.Знаток Паскаля младше специалиста по Си.В ответе сначала запишите первую букву имени 14-ти летнего программиста, затем через пробел первую букву его любимого языка программирования.

Даны действительные числа x, y. Если x и y отрицательны, то каждое значение заменить модулем; если отрицательно только одно из них, то оба значения

увеличить на 0,5; если оба значения неотрицательны и ни одно из них не пренадлежит отрезку [0.5;2,0], то оба значения уменьшить в 10 раз ; в остальных случаях x и y остаются без изменения . Помогите , завтра зачет.

В одном из изданий книги Л.Н. Толстого «Война и мир» 1024 страницы.

Какой объём памяти (в Мбайт) заняла бы эта книга, если бы Лев Николаевич
набирал её на компьютере в одной из кодировок Unicode? На одной странице
в среднем помещается 64 строки, а в строке 64 символа. (Каждый символ
в кодировке Unicode занимает 16 бит памяти.)
Помогите пожалуйста))

Имеется 52-ух карточная колода и два юных дарования: Лорелея и Уарт. Если каждый из учеников вытащит наугад одну из 52-ух карт, у кого будет больше

шансов на удачу: у Лорелеи, пообещавшей достать одного из четырёх тузов, или у Уарта, заявившего, что он сразу же вытащит карту червонной масти? Получит ли Лорелея больше шансов вытащить двух тузов, если она вернёт первого в колоду? Или если она отложит его в сторону? Будет ли у Уарта больше шансов вытащить две карты червонной масти, если он вернёт первую в колоду? Или если он отложит её в сторону?

Запишите строку русских букв ,про которую неверно не одно из утверждений:

1. её длина больше 7
2.её длина меньше 5
3. в этой строке встречаются две гласные буквы стоящие рядом
4.строка начинается с гласной буквы
5в строке нет ни одной буквы А
6.в строке есть только одна из букв А, Б, В



Вы находитесь на странице вопроса "Витя работает недалеко от одной из станций кольцевой линии Московского метро, а живет рядом с другой станцией той же линии. Требуется выяснить, мимо", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.