Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Язык Borland C++ никаких паскалей

5-9 класс

Написать программу,позволяющую для заданного одномерного массива А из n вещественных или целых элементов реализовать обработку массива.Длина массива N
задается пользователем как константное выражение.Исходные данные задать вручную или с помощью генератора случайных чисел,учитывая формат элементов массива А.Тип результата определяется из контекста.
-Вычислить количество отрицательных элементов массива;
-сумму модулей элементов массива,расположенных после максимального элемента

Van245 28 нояб. 2014 г., 19:42:40 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Evgevg12345
28 нояб. 2014 г., 21:35:49 (9 лет назад)

#include <cstdlib>
#include <iostream>

using namespace std;

int main(int argc, char *argv[])
{int i,k,max,j,n,s;
srand(time(NULL)); k=0; s=0;
cout<<"Введите размерность массива:"<<endl;
cin>>n;
int a[n];
cout<<"Данный массив:"<<endl;
for (i=0;i<=n;i++) {a[i]=rand()%21-10; cout<<a[i]<<" ";}
max=a[0]; j=0;
for (i=0;i<=n;i++) {if (a[i]<0) k=k+1; if (a[i]>max) {max=a[i]; j=i;}}
cout<<"Количество отрицательных элементов - "<<k<<endl;
for (i=j+1;i<=n;i++) s+=abs(a[i]);
cout<<"Сумма модулей элементов массива, расположенных после максимального - "<<s<<endl;

    system("PAUSE");
    return EXIT_SUCCESS;
}


Ответить

Другие вопросы из категории

. Составьте программу (полный текст программы) для решения следующей задачи. Введите с клавиатуры три числа: А, В, С. Если все они четные, то найдите и

выведите на экран их сумму. Если все они нечетные и A>B>C, то определите и выведите значения наибольшего и наименьшего из чисел. Иначе, выведите числа без изменения. Фрагмент программы: if (a mod 2 = 0) and (b mod 2 = 0) and (c mod 2 = 0) then begin S:=a+b+c; writeln('сумма равна ', S); end; if (a mod 2 <> 0) and (b mod 2 <> 0) and (c mod 2 <> 0) and (a>b) and (b>c) then begin writeln('наибольшее число ', A); writeln('наименьшее число ', C); end else writeln('a= ',a,' b= ', b, ' c= ',c);

Читайте также

как перевести на язык программирования бейсик и паскаль эти выражения y³-6y=0; 6x⁴+3,6x²=0; x³+3x=3,5x²; x³-0,1x=0,3x²;

9x³-18x²-x+2=0;

y⁴-y³-16y²+16y=0;

p³-p²=p-1;

x⁴-x²=3x³-3x.

пожалуйста помогите

мне нужна помощь ещё с одной задачей.

Нужно на языке программирования в программе Паскаль, создать программу:
Найти произведение, сумму и количество всех отрицательных чисел на отрезке [x;y].

РЕШИТЕ ПОЖАЛУЙСТА!!! Сформировать массив множителей заданного числа. Язык программирования - паскаль.ПОМОГИТЕ, ПОЖАЛУЙСТА!!! дана матрица

B(4,3). Заменить отрицательные элементы произведением положительных элементов. Языка программирования - паскаль.

Помогите, пожалуйста, очень нужно! Срочно!:( 1) Не используя функцию возведения в квадрат, напишите на языке Паскаль наиболее короткие алгоритмы

вычисления: а) y=x^10 б) y=x^15. Постараться использовать минимальное количество дополнительных переменных. 2) Дана сторона равностороннего треугольника. Найти площадь этого треугольника, его высоты, радиусы вписанной и описанной окружностей. Программу записать на языке Паскаль. 3) Дана величина А, выражающая объём информации в байтах. Перевести А в более крупные единицы измерения информации. Программу записать на языке Паскаль

Плиз срочно надо.1)Найдите правильную на языке паскаль запись выражения

19(16,3+7,7).а)19(16.3+7.7),в)19*(16.3+7.7).д)19(16,3+7.7).с)19*(16.3+7.7).2)Найдите правильную на языке паскаль записы выражения \frac{34,5+24,5}{15y}.а)34.5+24.5/15у в)(34.5+24.5)/15у с)(34.5+24.5)15*у.д)(34.5+24.5)/(15*у).3)Вычислите длину окружности и площадь круга одного и того же заданного радиуса R.4)Даны два числа.Найдите среднее арифметическое кубов этих чисел и среденее геометрическое модулей этих чисел.Два последних номера там нужно написать программу,программу присылать на листочке



Вы находитесь на странице вопроса "Язык Borland C++ никаких паскалей", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.