Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Помогите пожалуйста! Нужно вытянуть оценку!!!

5-9 класс

Напишите процедуру ввода N элементов массива из файла. Отсортируйте по невозрастанию методом простого обмена. (Паскаль)

Eleena160 21 мая 2013 г., 23:07:52 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
наиляшка
22 мая 2013 г., 1:36:03 (10 лет назад)

var  i,j,n,k: integer; 
 a: array [1..100] of integer;
begin
assign (input,'input.txt');
reset(input);
assign(output,'output.txt');
rewrite(output);
readln (n);
for i:=1 to n do
read(a[i]);
for i:=1 to n do 
for j:=1 to n-i do
 if a[j+1]>a[j]
then begin k:=a[j]; a[j]:=a[j+1]; a[j+1]:=k; end;
for i:=1 to n do
write (a[i],' ');
end.

Входные данные писать в файл input.txt в формате:
n
a[i] a[i+1] a[i+2]...a[n].

Ответить

Другие вопросы из категории

1.Придумайте три своих способа кодирования русских букв,используя различные формы представления информации.

2.Какой алфавит нашел наибольшее распространение в различных сферах деятельности?Как называются символы этого алфавита?

Проверочная работа по теме

«Аппаратное обеспечение компьютера»

1) Архивный файл может иметь расширение:
a) . xls;
b) .mp3;
c) .bmp;
d) .zip;
e) .doc.

2) Графическим является файл c расширением:
a) .exe;
b) .htm;
c) .xls;
d) .bmp;
e) .doc.

3) Специально написанная программа, которая присоединяется к другим программам и портит software:
a) архиватор;
b) интерпретатор;
c) компьютерный вирус;
d) драйвер;
e) транслятор.

4) Основные компоненты функциональной схемы компьютера:
a) клавиатура, монитор, дисковод, системный блок;
b) устройства ввода-вывода, процессор, внутренняя память, внешняя память;
c) монитор, винчестер, принтер, дисковод;
d) устройства ввода-вывода, арифметико-логическое устройство, устройство управления, оперативная память;
e) клавиатура, мышь, монитор, дисковод, принтер, сканер.

5) Во время исполнения программа находится в:
a) клавиатуре;
b) процессоре;
c) буфере обмена;
d) мониторе;
e) оперативной памяти.

6) Исполняемым является файл c расширением:
a) .xls;
b) .htm;
c) .exe;
d) .bmp;
e) .doc.

7) Архиватор — это программа, предназначенная для:
a) резервного копирования файлов;
b) хранения редко используемых программных файлов;
c) сжатия файлов;
d) защиты от компьютерных вирусов;
e) расширения возможностей ОС.

8) Действие, безвозвратно удаляющее объект Windows:
a) перетащить значок объекта в корзину;
b) выделить объект и нажать клавишу на клавиатуре;
c) в контекстном меню выбранного объекта выполнить команду Удалить;
d) выделить объект и нажать клавишу при нажатой клавише ;
e) выделить объект и выполнить команду меню Файл  Удалить.

9) Укажите, какая информация не является объективной:
a) «На улице холодно»;
b) «У кошки четыре лапы»;
c) «Поезд № 23 отправляется с 3-го пути»;
d) «На улице 22С»;
e) «Париж — столица Франции».

10) Магистрально-модульный принцип архитектуры компьютеров предполагает следующую логическую организацию компонент:
a) каждое устройство связано с другими напрямую;
b) каждое устройство связано с другими через одну центральную магистраль;
c) каждое устройство связано с другими через магистраль, включающую в себя шины данных, адреса и управления;
d) устройства связаны друг с другом в заданной последовательности (кольцо);
e) связь устройств друг с другом через центральный процессор, к которому все подключены.

Читайте также

Помогите пожалуйста ! срочно надо!!!...в заданной последовательности целых чисел определите сумму элементов кратных 10! пример задачки вот именно под

типо по такой же системе которую щас напишу! program Maximum; i,n,max:integen; begin writeln ( 'введи элементы массива для поиска максимума'); for i:=1 to 10 do begin write ('a [', i ,']=');readln (a [ i ] ) ;end; max:=a[1]; for i = 2 to 10 do if a [ i ] > max then begin max:=a [ i ] ; n:= i ; end; writeln ('найти наибольший элемент ',max ,' под номером ', n); вот наподобие этого примера нужно построить мою задачу! в заданной последовательности целых чисел определите сумму элементов кратных 10. Помогите пожалуйста!!!

Помогите пожалуйсто решить прошу очень срочно!!!!

1. Чему равны значения переменных r, a, d?
a:=5; b:=20; c:=-7;
d:=2.5;
r := a+(4*b+c)*d;
a:= a+4;
d:=a*7;

2. В пяти тестовых опросах мальчик получил оценки. Составьте программу, которая определит среднее значение оценок, полученных мальчиком в пяти опросах.

3*. Задача. «Покупка в магазине»
Человек делает в магазине покупки. Определите сколько денег у него останется после покупки в магазине перчаток стоимостью А руб., портфеля стоимостью B руб. и галстука стоимостью D руб. Все исходные данные задаются с клавиатуры.

Исходные данные.
a — стоимость перчаток;
b — стоимость портфеля;
d — стоимость галстука;
dengi — количество денег у человека.
Все эти переменные будут вещественного типа.
Результат.
ostatok — количество денег, которое останется у человек (вещественный тип).
Метод решения.
ostatok = dengi – a – b – d
Написать программу, реализующую данную задачу
Помогите пожалуйсто решить очень срочно!!!!!!

Здравствуйте!Помогите пожалуйста с информатикой!

1.В ящике имеется 3 чёрных и 5 белых шаров.Какое наименьшее число шаров нужно взять из ящика ( не заглядывая в него), чтобы среди вытянутых шаров:.
1)Оказался хотя бы 1 чёрный
2)Оказался хотя бы 1 белый
3)Оказались хотя бы 2 чёрных
4)Окаазались хотя бы 2 белых
Если можно с решением,логическим рядом.
2. В одной книге было написано 100 следующих утерждений.
"В этой книге роно одно неверное утверждение"
"В этой книге ровно два неверных утверждения"
............................................................................................
"В этой книге ровно сто неверных утверждений.

Какое из этих утерждений верное?

Судя по моим мыслям,это явно не 3, тогда это получается правда, что противоречит смыслу предложения. Тогда какое получается? Я не знаю.Помогите пожалуйста. Напишите всё с решением пожалуйста.



Ах да,чуть не забыла. Если кто -то знает бесплатный решебник ( без всяких файлообменников) напишите пожалуйста.

Здравствуйте!Помогите пожалуйста с информатикой! 1.В ящике имеется 3 чёрных и 5 белых шаров.Какое наименьшее число шаров нужно взять из ящика ( не

заглядывая в него), чтобы среди вытянутых шаров:. 1)Оказался хотя бы 1 чёрный 2)Оказался хотя бы 1 белый 3)Оказались хотя бы 2 чёрных 4)Окаазались хотя бы 2 белых Если можно с решением,логическим рядом. 2. В одной книге было написано 100 следующих утерждений. "В этой книге роно одно неверное утверждение" "В этой книге ровно два неверных утверждения" ............................................................................................ "В этой книге ровно сто неверных утверждений. Какое из этих утерждений верное? Судя по моим мыслям,это явно не 3, тогда это получается правда, что противоречит смыслу предложения. Тогда какое получается? Я не знаю.Помогите пожалуйста. Напишите всё с решением пожалуйста. Ах да,чуть не забыла. Если кто -то знает бесплатный решебник ( без всяких файлообменников) напишите пожалуйста.



Вы находитесь на странице вопроса "Помогите пожалуйста! Нужно вытянуть оценку!!!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.