Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

привет,помогите пожалуйста решить еще задачки))))

5-9 класс

1)дано натуральное число N>1.найти количество его делителей
2)дано натуральное число N>1.равно ли оно сумме своих делителей(включая единицу,но не себя)
3)даны числа a и n.вычислить:1/a 1/a*a 1/a*a*a ... 1/a*n
это все цикл for,зарание спасибо!

Annabezgan83 13 июля 2013 г., 9:56:34 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Deadred
13 июля 2013 г., 11:24:14 (10 лет назад)

1)

Program n1;
Uses CRT;
Var k,n,i: integer;
begin
Writeln('Vvedite N');
readln(n);
For i:=1 to N do
if n mod i=0 then k:=k+1;
Writeln('Delitelei ',k,' vkluchaya 1 i ',n);
readln
end.

 

 

2)

Program n1;
Uses CRT;
Var k,n,i: integer;
begin
Writeln('Vvedite N');
readln(n);
For i:=1 to N-1 do
if n mod i=0 then k:=k+i;
If k=n then writeln ('chislo ravno summe delitelei') else writeln('ne ravno');
readln
end.

 

 

3) Вычислить, я так поняла, сумму всего этого?

Program n1;
Uses CRT;
Var k,n,i,j,a: integer; s: real; p: longint;
begin
Writeln('Vvedite a,N');
readln(a,n);
p:=1;
For i:=1 to n do
For j:=1 to i do
p:=p*a;
s:=s+1/p;
writeln(s);
readln
end.

Ответить

Другие вопросы из категории

Помогите решить задачу на языке программирования в Turbo Pascal, плиз Начав тренировки, лыжник в первый день пробежал 10 км. Каждый следующий день он

увеличивал пробег на 10% от пробега предыдущего дня. Определить: а) ежедневное увеличение пробега лыжника за третий, четвёртый, ..десятый день тренировок; б) средний путь лыжника за первые 8 дней тренировок; в) сколько дней он будет бегать менее, чем по 15 км; г) в какой день суммарный пробег за все дни превысит 90 км.

Даны числа a,b,c. Составить программу, выводящую на экран сообщение, в зависимости от того какой треугольник можно построить с такими длина сторон:

равносторонний,равнобедренный или какой либо другой.

Вот ещё одна

Составить программу:Даны а,b,c-целые числа.Если они большн 0-вычислите сумму их квадратов;а если хотя бы одно из них четно-вычислите их сумму и произведение.

Пожалуйста ребят.

Задача 1

Для записи текста используется 128-ми символьный алфавит.30 строк по 70 символов
Сколько мегабайтов информации несет 200 стр текста?
Задача 2
Для записи текста используется 256-ми символьный алфавит текст набраный этим алфавитом содержит 4 кб информации и занимает 4 стр
Сколько символов в строке если на странице 16 символов

Читайте также

Помогите пожалуйсто решить прошу очень срочно!!!!

1. Чему равны значения переменных r, a, d?
a:=5; b:=20; c:=-7;
d:=2.5;
r := a+(4*b+c)*d;
a:= a+4;
d:=a*7;

2. В пяти тестовых опросах мальчик получил оценки. Составьте программу, которая определит среднее значение оценок, полученных мальчиком в пяти опросах.

3*. Задача. «Покупка в магазине»
Человек делает в магазине покупки. Определите сколько денег у него останется после покупки в магазине перчаток стоимостью А руб., портфеля стоимостью B руб. и галстука стоимостью D руб. Все исходные данные задаются с клавиатуры.

Исходные данные.
a — стоимость перчаток;
b — стоимость портфеля;
d — стоимость галстука;
dengi — количество денег у человека.
Все эти переменные будут вещественного типа.
Результат.
ostatok — количество денег, которое останется у человек (вещественный тип).
Метод решения.
ostatok = dengi – a – b – d
Написать программу, реализующую данную задачу
Помогите пожалуйсто решить очень срочно!!!!!!

Люди Люди Люди если вы читаете это сообщение значит вы просто обязаны помочь! пожалуйста если у вас есть паскаль помогите пожалуйста решить первое и

второе задание ну или хотя бы только первое .Это вопрос жизни и смерти помогите пожалуйста P.S задание во вложениях.заранее спасибо и знайте если вы поможете значит вы самый добрый и отзывчивый человечек!)

помогите пожалуйста! никак не могу с ноутбука зайти в вконтакт, но с телефона получается.появляется (ну это у всех) введите свой e-mail (или

телефон) и пароль .я ввожу, нажимаю войти, потом появляется картинка и говорят "Введите код с картинки" (эту функцию я отключила несколько лет назад!!! ) ,ну я думаю, хорошо, я введу, подумаешь три буковки. ВОТ! После этого проблема. мне пишут " Лена, мы зафиксировали попытку взлома Вашей страницы. Не беспокойтесь, она в безопасности. Чтобы обезопасить Вашу страницу от злоумышленников и в будущем, мы просим Вас подтвердить привязку к телефону и придумать новый сложный пароль. " Ладно я ввожу свой номер телефона, чтоб мне пришел код активации. Раньше мне приходило вот это"Для активации услуги подтвердите Ваше согласие с правилами, Ответь ДА стоимость отправки смс на номер 4012 - 203.19"!!! А сейчас уже если я наберу номер ничего абсолютно не происходит. Ага! Еще чего, не буду я на них целых 200 рублей тратить! Помогите пожалуйста мне решить эту проблему
И еще кое что, когда мой брат или подруга тоже попытались зайти в ВК у них всеё было тоже самое
С телефона пароль меняла, но ничего не изменилось

Помогите пожалуйста ! срочно надо!!!...в заданной последовательности целых чисел определите сумму элементов кратных 10! пример задачки вот именно под

типо по такой же системе которую щас напишу! program Maximum; i,n,max:integen; begin writeln ( 'введи элементы массива для поиска максимума'); for i:=1 to 10 do begin write ('a [', i ,']=');readln (a [ i ] ) ;end; max:=a[1]; for i = 2 to 10 do if a [ i ] > max then begin max:=a [ i ] ; n:= i ; end; writeln ('найти наибольший элемент ',max ,' под номером ', n); вот наподобие этого примера нужно построить мою задачу! в заданной последовательности целых чисел определите сумму элементов кратных 10. Помогите пожалуйста!!!



Вы находитесь на странице вопроса "привет,помогите пожалуйста решить еще задачки))))", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.