Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Создайте массив из n

5-9 класс

элементов (1 < n < 20) и найдите произведение всех его элементов.
Элементы массива вводятся генератором случайных чисел.

Bllodfast 13 дек. 2016 г., 21:57:43 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Chigrinskii82
13 дек. 2016 г., 23:12:17 (7 лет назад)

var
  a: array of integer;
  i, n: integer;
  k: longint := 1;

begin
  readln(n);
  a := new integer[n];
  n -= 1;
  for i := 0 to n do
  begin
    a[i] := random(10);
    writeln('a[', i, '] => ', a[i]);
  end;
  writeln();
  foreach i in a do
    k *= i;
  writeln(k);
end.

+ 0 -
лена5126
14 дек. 2016 г., 1:54:51 (7 лет назад)

var
  a: array [1..20] of integer;
  i, n: integer;
  k: longint;

begin
  readln(n);
  k := 1;
  for i := 1 to n do
  begin
    a[i] := random(10);
    write(' ', a[i]);
  end;
  writeln();
  for i := 1 to n do
    k := k * a[i];
  writeln(k);
end.

Ответить

Другие вопросы из категории

Для получения годовой оценки по МХК ученику требовалось написать доклад на 8 страниц. Выполняя это задание на компьютере, он набирал текст в кодировке

Unicodc. Какой объем памяти (в Кбайтах) займет доклад, если в каждой строке по 32 символа, а на каждой странице помещается 64 строки? Каждый символ в кодировке Unicode занимает 16 бит памяти. 1) 16 2) 32 3) 64 4) 256

Читайте также

1). Дан массив из n элементов (n >= 4). Подсчитать среднюю арифметическую второго и предпоследнего элемента массива.

2). Дан массив из n элементов. Написать программу подсчитывающую произведение элементов массива.

1)Задан массив из 11 целых чисел. Найти сумму элементов массива, кратных 5 2)Задан массив из 11 целых чисел. Посчитать количество нечётных

элементов массива.

3)задан массив из 9 целых чисел.Вывести на экран чётные элементы

решить через паскаль через массивы)) 1.Дан одномерный массив из 10 элементов. Заменить все большие 7 члены массива числом 7. Найти количество

таких членов.

2.Дан массив из 10 элементов. Найти количество элементов с четными индексами.

3.Дан массив из 10 элементов. Найти наибольший элемент массива.

1. Разработать схему алгоритма, который вводит массив из N целых

чисел и выводит на экран этот же массив в прямом и обратном порядке. Протестировать алгоритм на произвольных массивах, состоящих из 1 числа, из 5 чисел, из 10 чисел.

2. Разработать схему алгоритма, который вводит массив из N целых чисел и выводит на экран элементы с чётными номерами. Протестировать алгоритм на произвольных массивах размерностью 5 и 8 элементов.

3. Разработать схему алгоритма, который вводит массив из N целых чисел и выводит на экран элементы с нечётными номерами в обратном порядке. Протестировать алгоритм для следующих исходных данных:

а) 1 3 5 6 8 9

б) -1 4 6 2 4 6 8 6 9

P.S. Убедительная просьба написать решение целиком и до наступления ночи. Я являюсь дилетантом в Паскале, а эти три задачи являются моим домашним заданием по информатике на завтра.



Вы находитесь на странице вопроса "Создайте массив из n", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.