Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

ПОМОГИТЕ РЕШИТЬ ПРОГРАММУ ПО ИНФОРМАТИКЕ : Дан одномерный массив S(N). Определить количество элементов, равных среднему значению массив S(N). Заменить эти

10-11 класс

элементы на 100

Pelo 30 авг. 2014 г., 0:32:17 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Lena0226
30 авг. 2014 г., 3:15:15 (9 лет назад)

for i:= 1 to n do
begin
sr_arf = sr_arf +s[i]; - считаем сумму всех элементов
end;
sr_arf=sr_arf/n; - считаем среднее арифметичкое
for i:= 1 to n do
if (s[i] = sr_arf) then - если текущий элемент равен среднему арефм-му
begin
kol:=kol+1; считаем количество элементов
s[i] := 100; присваиваем текущему элементу 100
end;



Ответить

Другие вопросы из категории

Дан массив из 5 элементов:4, 3, 14, 6, 12.

Разработать блок-схему алгоритма сортировки
элементов в порядке возрастания,
найти максимальный и минимальный
элементы.

Наташа набрала текст на компьютере. Текст получился на 12 страниц, каждая страница состоит из 24 строк, в каждой строчке 21 символ. Определите

информационный объём получившегося текста в одной из кодировок Unicode? в которой каждый символ кодируется 16 битами.
А)12, 4Кбайт
В)16,1Кбайт
С)300Кбайт
D)1024Кбайт

Читайте также

Паскаль помогите пжл!!!!!! Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива,

расположенных между максимальным и минимальным элементами.

Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива, расположенных между максимальным по модулю и минимальным по модулю элементами

ну или исправьте мое пжл

program fgf;
var mas:array[1..100] of real;
max,min:real;
i,n,c,b:shortint;
p:real;
f1,g:text;
begin;
assign (f1, 'input.txt');
reset (f1);
readln (f1, n);

for i:=1 to N do read (mas[i]);
max:=mas[i];
for i:=2 to N do begin
if mas[i]>max then begin
max:=mas[i];
c:=i;
end;
end;
min:=mas[1];
for i:=2 to N do begin
if mas[i]<min then begin
max:=mas[i];
b:=i;
end;
end;
close(f1);
assign (g, 'output.txt');
rewrite (g);
p:=1;
if b<c then I:=b+1 and c-1

else for I:=c+1 to b-1 do p:=p*mas[i];

if (n<3) or (b+1=c) or (c+1=b) then writeln(g,'0.00') else write(p:3:3) ;

close (g);
end.

ПОМОГИТЕ РЕШИТЬ ЗАДАЧУ ПОЖАЛУЙСТА.я пропустила тему.ПО ПАСКАЛЬ.!!

Дан одномерный массив А состоящий из 10 элементов.Вывести на экран исходную таблицу и резултат программы.
Найти произведения элементов массива А. удовлетворяющих условию:
c<=A[i]<=d.

Помогите, пожалуйста, решить задачу по информатике)

1. Напишите программу формирования и вывода массива размером 6x3, каждые три последовательных элемента в строке которого составлены по следующему правилу:
1-й — равен случайному числу;
2-й — равен целой части квадратного корня из предыду­щего элемента;
3-й-равен сумме двух предыдущих элементов.



Вы находитесь на странице вопроса "ПОМОГИТЕ РЕШИТЬ ПРОГРАММУ ПО ИНФОРМАТИКЕ : Дан одномерный массив S(N). Определить количество элементов, равных среднему значению массив S(N). Заменить эти", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.