Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

в двух файлах записано по 10 чисел, создать третий файл ,в котором чередуются числа первых двух файла. Написать в программе PascalABC

10-11 класс

Кэтти28 10 мая 2014 г., 22:06:01 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Enean
11 мая 2014 г., 0:25:36 (10 лет назад)

var
  f1, f2 :array [1..10] of integer;
  i :integer;
  input, output :text;
 
begin

  assign(input,'input1.txt');
  reset(input);
  for i:= 1 to 10 do 
    read(input,f1[i]);
  close(input);
 
  assign(input,'input2.txt');
  reset(input);
  for i:= 1 to 10 do 
    read(input,f2[i]);
  close(input);
 
  assign(output,'output.txt');
  rewrite(output);
  for i:= 1 to 10 do
  begin
    writeln(output,f1[i]);
    writeln(output,f2[i]);
  end;
  close(output);

end.

+ 0 -
Klepkaaa
11 мая 2014 г., 2:22:48 (10 лет назад)

var
  input1, input2, output : Text;
  i, number : integer;
begin
  AssignFile(input1, 'input1.txt');
  AssignFile(input2, 'input2.txt');
  AssignFile(output, 'output.txt');
  Reset(input1);
  Reset(input2);
  Rewrite(output);
  for i := 1 to 10 do
  begin
    read(input1, number);
    write(output, number, ' ');
    read(input2, number);
    write(output, number, ' ');
  end;
  CloseFile(input1);
  CloseFile(input2);
  CloseFile(output);
  writeln('Готово');
end.  

+ 0 -
B1zOo
11 мая 2014 г., 5:13:37 (10 лет назад)

Названия файлов какие?

+ 0 -
Fayzullina1
11 мая 2014 г., 7:51:39 (10 лет назад)

без разницы

Ответить

Читайте также

20,9- Перевести их в 2-ую, 8-ую и 16-ую, системы счисления. Выполнить в этих системах их сложение, вычитание и умножение. Ответ записать в 10-ой

системе счисления.

80,1- Перевести их в 2-ую, 8-ую и 16-ую, системы счисления.

Выполнить в этих системах их сложение, вычитание и умножение.

Ответ записать в 10-ой системе счисления.

1. Написать программу, которая выводит на экран сумму средних арифметических значений двух вещественных массивов из 10 элементов.

2. Написать прогрумму,которая выводит на экран, разность значений двух вещественных массивов из 10 элементов.

Создать файл,в которм хранятся данные о работающих на фабрике:фамилия,имя,отчество,адрес(улица,дом,квартира) и дата поступления на

работу(месяц,год). Во второй файл записать строки с адресами тех работников, у которых фамилия Иванов или Иваова

Срочно!!!Задача D. "Города и дороги" В одномЗадача D. "Города

и дороги"

В
одном царстве есть N городов, некоторые из которых соединены дорогами. Царь
решил провести инвентаризацию дорог в своем государстве. Но, как оказалось, он
не силен в математике, поэтому он просит вас сосчитать количество дорог.

Формат входного файла В файле INPUT. IN записано число N
(0≤N≤100). В следующих N строках записано по N чисел, каждое из которых
является единичкой или ноликом. Причем, если в позиции (i,j) квадратной матрицы
стоит единичка, то i-ый и j-ый города соединены дорогами, а если нолик, то не
соединены.

Формат выходного файла В файл OUTPUT.
OUT вывести одно число - количество дорог в царстве.

Примечание.
Все дороги двусторонние, то есть если есть дорога из города i в город j, то
есть и дорога из города j в город i, и это та же самая дорога.

Примеры:




INPUT. IN


OUTPUT. OUT




5
0 1 0 0 0
1 0 1 1 0
0 1 0 0 0
0 1 0 0 0
0 0 0 0 0


3



Вы находитесь на странице вопроса "в двух файлах записано по 10 чисел, создать третий файл ,в котором чередуются числа первых двух файла. Написать в программе PascalABC", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.