Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Срочно!!!Задача D. "Города и дороги" В одномЗадача D. "Города

10-11 класс

и дороги"

В
одном царстве есть N городов, некоторые из которых соединены дорогами. Царь
решил провести инвентаризацию дорог в своем государстве. Но, как оказалось, он
не силен в математике, поэтому он просит вас сосчитать количество дорог.

Формат входного файла В файле INPUT. IN записано число N
(0≤N≤100). В следующих N строках записано по N чисел, каждое из которых
является единичкой или ноликом. Причем, если в позиции (i,j) квадратной матрицы
стоит единичка, то i-ый и j-ый города соединены дорогами, а если нолик, то не
соединены.

Формат выходного файла В файл OUTPUT.
OUT вывести одно число - количество дорог в царстве.

Примечание.
Все дороги двусторонние, то есть если есть дорога из города i в город j, то
есть и дорога из города j в город i, и это та же самая дорога.

Примеры:




INPUT. IN


OUTPUT. OUT




5
0 1 0 0 0
1 0 1 1 0
0 1 0 0 0
0 1 0 0 0
0 0 0 0 0


3

Voropaev0408 04 авг. 2014 г., 14:23:59 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Rfvbkkf1
04 авг. 2014 г., 15:08:17 (9 лет назад)

var n,s,j,i: integer;
a:array[1..15,1..15] of integer;
begin
writeln ('введите число');
readln(n);
for j:=1 to n do
for i:=1 to n do readln
(a[i,j]);
for j:=1 to n do begin
for i:=1 to n do begin
write (a[i,j],'  '); 
end;
writeln;
end; 
for j:=1 to n do begin
for i:=j to n do begin
if (i>j) and (a[i,j]=1) then s:=s+1;
end;end;
writeln ('s=',s);
end.          'Эта задача с олимпиады? В решении ввод данных идет с клавиатуры.Сначала вводим размер матрицы n, затем по одному элементу массива

Ответить

Читайте также

помогите, ПОЖАЛУЙСТА! СРОЧНО!!!задача по турбо паскаль. Определить сколько метров сетки нужно, чтобы загородить большой сад почти прямоугольной

формы со сторонами a, b, и сколько удобрений (d) надо купить, если на 1 м2 требуется с кг? (р = 2(а+b), d = abc)

Задача 1. Счастливые билетики по–ярославски

Есть счастливые билетики по–московски, есть счастливые билетики по–питерски, но мало кто слышал про счастливые билетики по–ярославски. В ярославском общественном транспорте номера билетиков состоят из 2N цифр. Билетик называется счастливым, если ярославская сумма первых N цифр равна ярославской сумме последних N цифр. Требуется найти количество счастливых билетиков по–ярославски для заданного N. На первый взгляд, задача простая, но что же такое «ярославская сумма»? Для заданного числа k найдем сумму его цифр, если получившееся число состоит из двух и более цифр, то найдем сумму цифр этого числа и т. д., пока не получим число, состоящее из одной цифры. Такая сумма цифр называется «ярославской суммой цифр». Билетики нумеруются от 00…000 до 99…999.
Вход: файл input.txt, в первой строке которого записано натуральное число N.
Ограничения: 1 ≤ N ≤ 1000
Выход: файл output.txt, содержащий одно число – количество счастливых билетиков по модулю109+7 (т.е. остаток от деления количества счастливых билетиков на 109+7)
Примеры
input.txt output.txt
1 10
6 110888113
Задача 2. Замощение улицы
Новый мэр Эль-Пасо Авраам Гарфилд решил замостить главную улицу города и для этой работы нанял бригаду рабочих во главе с Джорджем Шерманом. Улица представляет собой полосу длиной 4*N метров. Бригада Джорджа будет покрывать её плитками размера 1*2 метра. Плитки можно укладывать как горизонтально, так и вертикально. Шермана интересует, сколькими способами он может замостить главную улицу Эль-Пасо. Так как это число может быть очень большим, то от вас требуется найти число замощений по модулю 109+7 (т.е. найти остаток от деления количества замощений при делении на 109+7).
Вход: файл input.txt, в первой строке которого записано натуральное число N (ширина дороги в Эль-Пасо).
Ограничения: 0 < N < 113
Выход: файл output.txt, содержащий одно число – количество различных способов замостить улицу плитками 1*2 по модулю 109+7 (т.е. остаток от деления количества способов замостить улицу на 109+7).
Примеры
input.txt output.txt
2 5
3 11
7 781
Пояснение к примерам
Улицу длиной 4*2 метра (первый тест из примеров) можно замостить 5 следующими способами:

Задача 3. Упаковка печенья
На вас, как на главном программисте компании по производству печенья, лежит много ответственных заданий. Одно из них – производство и упаковка печенек должна соответствовать самым высоким требованиям Ярославского Консорциума по упаковке печенья.
В любой момент ваша линия производства выпускает новые печеньки, которые хранятся в печенькохранилище, ожидая упаковки. Время от времени поступают запросы с конвейера по упаковке – отправить из печенькохранилища ту печеньку, которую нужно упаковать. Перед поступлением в хранилище, диаметр каждой печеньки измеряется с точностью до 1 нанометра. На упаковку отправляется печенька, являющаяся медианой среди всех печенек. Что такое медиана? Если мы отсортируем печеньки по возрастанию диаметров, то, если печенек нечетное количество c, то на упаковку идёт печенька на позиции (c+1)/2 в отсортированной последовательности. Если же c – четное число, то печенька на c/2+1 в отсортированной последовательности. Если печеньку отправляют на упаковку, то она пропадает со склада. Ваша задача – промоделировать работу системы упаковки печенек.
Вход: файл input.txt, в каждой входной строке которого содержится либо положительное число d, означающее, что в хранилище поступает новая печенька диаметром d нанометров, либо символ '#', означающий запрос с конвейера по упаковке.
Ограничения: 1 ≤ d ≤ 300 000 000; количество строк ввода не более 600 000; также следует считать, что хранилище пусто до тех пор, пока туда не поступит первая печенька.
Выход: файл output.txt, содержащий несколько строк – после каждого запроса на упаковку в отдельную строку выводится диаметр печеньки, которая отправляется на упаковку.
Примеры
input.txt output.txt
1
2
3
4
#
#
#
# 3
2
1
4
1
#
2
#
3
#
4
# 1
2
3
4



Задача № 1

Тронувшись с места, автомобиль каждую секунду увеличивает скорость на а км/ч.
На этом участке дороги существует ограничение V км/ч. Выяснить, через сколько полных секунд автомобиль превысит предельно допустимую скорость V?
Задача №2
Даны действительные числа а, b, c. Определить, можно ли построить треугольник со сторонами а, b, c или нет
Язык ПАСКАЛЬ =)



Вы находитесь на странице вопроса "Срочно!!!Задача D. "Города и дороги" В одномЗадача D. "Города", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.