Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Помогите пожалуйста.

10-11 класс

PASCAL

DIANA14112002 12 февр. 2017 г., 12:55:25 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Latysheva200333
12 февр. 2017 г., 14:22:00 (7 лет назад)

var
  i: integer;
  s: real;

begin
  s := 0;
  for i := 1 to 10 do s := s + cos((i * Pi) / (i + 2));
  Writeln('s=', s)
end.

Тестовое решение:
s=-4.92195395152977

var
  a, b, c, d, m, h, x, y: real;

begin
  Write('Веедите через пробел a,b,c,d,m,h: ');
  Readln(a, b, c, d, m, h);
  x := m;
  repeat
    y := a + b * exp(d * ln(cos(x))) + c * sqr(x);
    if y <= 10 then begin
      Writeln('x=', x, ' y=', y);
      x := x + h
    end
  until y > 10
end.

Тестовое решение:
Веедите через пробел a,b,c,d,m,h: 1.3 -2.7 10.35 0.543 0.12 0.05
x=0.12 y=-1.24039935528273
x=0.17 y=-1.07968072159701
x=0.22 y=-0.863526323266588
x=0.27 y=-0.591921889149891
x=0.32 y=-0.264848754434378
x=0.37 y=0.117716680407458
x=0.42 y=0.55580364578667
x=0.47 y=1.04944788422624
x=0.52 y=1.59869275678093
x=0.57 y=2.20359062842676
x=0.62 y=2.86420460482557
x=0.67 y=3.58061071877361
x=0.72 y=4.35290070133409
x=0.77 y=5.18118552562693
x=0.82 y=6.06559998930295
x=0.87 y=7.00630871931947
x=0.92 y=8.00351416419185
x=0.97 y=9.05746742705281





Ответить

Другие вопросы из категории

Помогите пожалуйста

Заранее спасибо

В парламенте некоторой страны две палаты, имеющие

равное число депутатов. В голосовании по важному вопросу приняли участие все
депутаты, причем воздержавшихся не было. Когда председатель сообщил, что
решение принято с преимуществом в 23 голоса, лидер оппозиции заявил, что
результаты голосования сфальсифицированы. Как это он понял?

Читайте также

Помогите пожалуйста.

Требуется написать Блокнот на делфи.
Написал всё, кроме кнопки "Сохранить" не пойму как сделать так, что бы при нажатии она работала как и в блакноте обычном.
Помогите пожалуйста :)

ПОМОГИТЕ, ПОЖАЛУЙСТА, ПРОСТО РАЗЪЯСНИВ ЗАДАНИЕ. ПЖЛ)))

.................................................................................................................................
Возьмите прайс лист любого компьютерного магазина или скачайте в интернете;
Составьте конфигурацию компьютера для специалиста вашей профессии;
Подберите программное обеспечение, поясните, для каких целей будут служить данные программы;
Посчитайте общую стоимость данной конфигурации по прайс листу
....................................................................................................................................
Учусь я на бухгалтера-экономиста.
Давайте думать вместе) Допустим, "специалист вашей профессии" - это бухгалтер. Я беру прайс лист (т.е. лист, где написаны наименования и цены всех товаров). Что такое конфигурация? Как её составить по этому прайс листу, если там и так всего цена и наименования известны...?)))) ПО подобрать, допустим, это будет ;MS Office Excel; для создания таблиц, а для данной задачи для подсчёта общей стоимости конфигурации; и ;MS Office World; для писания отчётов. Что же такое эти "конфигурации"?)))
Помогите, пожалуйста) не пропускайте вопрос)

Помогите, пожалуйста, составить алгоритм для следующей задачи: Вводятся четыре числа. Известно, что 3 из них равны, а 4-ое отличается от 3-ех других.

Нужно выдать число, которое отличается от других равных, при этом, используя ровно две операции сравнения. Я пытался решить эту задачу и через максимум-минимум, и через условия, но везде натыкался на грабли. Помогите, пожалуйста, разобраться. Заранее благодарю! Перед выставлением решения, рассмотрите следующие варианты: "2 4 4 4", "2 3 2 2 ", "-3 -3 -2 -3", "-4 -4 -4 -5".

Помогите, пожалуйста, разобраться и составить верный алгоритм. В задаче требовалось написать программу на Паскале и сравнить её с приведенной в учебнике.

"Подсчитайте кол-во операций в приведенном алгоритме (Ответ приведите в виде функции от параметра n)." Подсчитать кол-во операций самому - это возможно, а как привести ответ в виде функции от параметра n - я не знаю. Помогите, пожалуйста, понять это задание. Заранее благодарен!

Помогите пожалуйста!) Напечатать программу в паскале......

Пожалуйста...Срочно...Завтра крайний срок сдачи...Помогите...

Дан массив строк без пробелов. Напечатать строки, вторая половина которых не содержит цифры.



Вы находитесь на странице вопроса "Помогите пожалуйста.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.