Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

СРОЧНО, ПОЖАЛУЙСТА, НАПИШИТЕ КТО-НИБУДЬ, НА ЗАВТРА НАДО, УМОЛЯЮ, ТОЛЬКО ПРАВИЛЬНО!!!Я

10-11 класс

УЖЕ 20 РАЗ ЭТО ЗАДАНИЕ ПОСЫЛАЮ, НАПИШИТЕ!!! КТО СМОЖЕТ, ТОЛЬКО ПРАВИЛЬНО!

Ezhbaevaa 24 июля 2013 г., 9:52:31 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
AGSA
24 июля 2013 г., 12:30:27 (10 лет назад)

Program Zadacha1;
Const n = 17;
Var a: Array [1..n] of Integer;
i, b: Integer;
Begin
WriteLn('Введите ', n, ' чисел через пробел');
For i := 1 To n Do
Read(a[i]);
b := 1;
For i := 1 To n Do
If a[i] < 0 Then
b := b * a[i];
If b <> 1 Then
WriteLn('Произведение отрицательных чисел массива равно ', b)
Else
WriteLn('Массив не содержит отрицательных чисел');
ReadLn;
End.

Program Zadacha2;
Const n = 20;
Var a: Array [1..n] of Integer;
i, b, c: Integer;
d: Real;
Begin
WriteLn('Введите ', n, ' чисел через пробел');
For i := 1 To n Do
Read(a[i]);
b := 0;
c := 0;
For i := 1 To n Do
If a[i] Mod 3 = 0 Then
Begin
b := b + a[i];
c := c + 1;
End;
d := b / c;
If c <> 0 Then
Begin
WriteLn('Сумма чисел массива, кратных 3, равна ', b);
WriteLn('Количество чисел массива, кратных 3, равно ', c);
WriteLn('Среднее арифметическое чисел массива, кратных 3, равно ', d:3:2);
End
Else
WriteLn('Массив не содержит чисел, кратных 3');
ReadLn;
End.

+ 0 -
Lantatanja
24 июля 2013 г., 14:16:01 (10 лет назад)

Откуда брать элементы для массива? Пользователь вводит или случайные?

Ответить

Другие вопросы из категории

У меня проблемы, не могу решить задачу. Дано предложение. Нужно его зашифровать следующим методом - 3 первых буквы с 3 последними буквами этого

предложения и т.д. Т.е. к примеру дано предложение "QQQWWWeeeTTTWWW" после зашифровки должно быть так "WWWTTTeeeWWWQQQ"

1. Составить программу для нахождения произведения чисел от 1 до 15

2. Дан массив целых чисел. Найти Max элемент

БАЗА ДАННЫХ В Access! ПОМОГИТЕ!
Помогите, пожалуйста! Есть код программы в QBasic, нужно продолжить блок-схему.

Дана квадратная матрица. Найти минимальное значение среди элементов, расположенных выше главной диагонали.

Читайте также

СРОЧНО, ПОЖАЛУЙСТА, НАПИШИТЕ КТО-НИБУДЬ, НА ЗАВТРА НАДО,

УМОЛЯЮ, ТОЛЬКО ПРАВИЛЬНО!!!Я УЖЕ 30 РАЗ ЭТО ЗАДАНИЕ ПОСЫЛАЮ, НАПИШИТЕ!!! КТО СМОЖЕТ, ТОЛЬКО ПРАВИЛЬНО! КТО, ЧТО СМОЖЕТ, НО НАДО ВСЕ, НА ЗАВТРА!!!

СРОЧНО, ПОЖАЛУЙСТА, НАПИШИТЕ КТО-НИБУДЬ, НА ЗАВТРА НАДО, УМОЛЯЮ, Я УЖЕ 30 РАЗ ЭТО ЗАДАНИЕ ПОСЫЛАЮ, НАПИШИТЕ!!!

1.Дано массив 5*5, заполнить массив случайными числами не больше 30 и найти сумму парных элементов массива, которые находятся под главной диагонали и количество не парных элементов которые находятся над главной диагонали.

СРОЧНО, ПОЖАЛУЙСТА, НАПИШИТЕ КТО-НИБУДЬ, НА ЗАВТРА НАДО, УМОЛЯЮ, Я УЖЕ 30 РАЗ ЭТО ЗАДАНИЕ ПОСЫЛАЮ, НАПИШИТЕ!!! КТО СКОЛЬКО СМОЖЕТ!2-ЛЮБЫХ, ПО

ПРИМЕРУ(СМ. ВЛОЖЕНИЯ)

1. Создайте двумерный массив целых чисел размером 5*2, заполненный



Вы находитесь на странице вопроса "СРОЧНО, ПОЖАЛУЙСТА, НАПИШИТЕ КТО-НИБУДЬ, НА ЗАВТРА НАДО, УМОЛЯЮ, ТОЛЬКО ПРАВИЛЬНО!!!Я", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.