Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Дано натуральное число N. Определить, верно ли, что это число содержит ровно три одинаковые цифры.

10-11 класс

Решите алгоритмом

Nastya15963 28 авг. 2014 г., 19:23:14 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Olkon4048
28 авг. 2014 г., 22:06:37 (9 лет назад)

var
a,b,c,x:integer;
begin
write('Введите трехзначное число. X=');
readln(x);
a:=x div 100;
b:=(x mod 100) div 10;
c:=(x mod 10) div 1;
if (a=b) and (b=c) then writeln('Верно!')
else writeln('Не верно');
readln;
end.

Ответить

Другие вопросы из категории

бесполезная информация мешающая восприятию полезной

Срочно пажееееееееееее

Для кодирования секретного сообщенияДля кодирования секретного сообщения используются 14 специальных значков-символов.При этом символы кодируются

одним и тем же минимально возможным количеством бит.Чему равен информационный объем сообщения длиной в 256 символов?

Рисунок размером 92 на 2048 пикселей закодирован с палитрой 2 цвета. Сколько килобайт занимает в памяти рисунок? Рисунок размером 512 на 384 пикселей

занимает в памяти 168 Кбайт (без учёта сжатия). Найдите максимально возможное количество цветов в палитре изображения. Рисунок размером 448 на 128 пикселей закодирован с палитрой 2 цвета. Сколько килобайт занимает в памяти рисунок?

Читайте также

4 задачи: ввести натуральное число и определить, верно ли, что сумма цифр равна 10 (через repeat и until)//// ввести натуральное

число и определить, какие цифры встречаются несколько раз (через repeat и until)///

ввести целое число и найти сумму его цифр (через while)

ввести целое число и определить , верно ли, что в его записи есть две одинаковые цифры(через while)

всё через паскаль абс

Помогите пожалуйста решить 1) дано натуральное число. Определить номер цифры 3 в нем считая от конца числа. Если такой цифры нет то ответ

0,если их несколько то номер крайней правой.

2) Дано натуральное число. Определить сумму m его последних цифр

3)Дано натуральное число. определить его максимальную цифру.

4) дано предложение. заменить в нем все вхождения под строку str1 на подстроку str2

5) последовательность чисел Фибоначчи образуется так: первый и второй член последовательности равен 1, каждый следующий равен сумме двух предыдущих(1,1,2,3,5,,8,12..) Дано натуральное число n>=3 : а) найти k-й член последовательности б)получить первые n членов последовательности в)для заданного n определить верно ли,что сумма первых n членов есть четное число

Срочно!!!!

ввести натуральное число и определить, верно ли, что сумма цифр равна 10

1.Дано натуральное число:

a) найти произведение цифр числа б) верно ли, что в данном числе нет данной цифры А (цифру А вводить с клавиатуры)
2. Найти все трехзначные числа, которые при увеличении на 1 делятся на 2, при увеличении на 2 делятся на 3, при увеличении на 3 делятся на 4, а при увеличении на 4 делятся на 5.
3.Из данного натурального числа удалить все цифры А (а вводятся с клавиатуры).

Написать программы в паскале и желательно блок-схему, но можно и без нее.
Помогите пожалуйста)



Вы находитесь на странице вопроса "Дано натуральное число N. Определить, верно ли, что это число содержит ровно три одинаковые цифры.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.