Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Вывести в обратном порядке последнее слово строки. Подсчитать количество букв в нем.

5-9 класс

Markuly 30 мая 2014 г., 3:43:23 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Slava3550
30 мая 2014 г., 5:32:42 (9 лет назад)

на Паскаль (для Delphi и Lazarus, надо подкорректировать для PascalABC):
const
  V=255;
type L= array [1..V] of char;
var
  S: string;
  A: L;
  f,i: integer;
begin
  read(S);
  f:=0;
  for i:=1 to Length(S) do
  begin
    if S[i]<>' ' then begin f:=f+1; A[f]:=S[i] end
    else f:=0;
  end;
  for i:=f downto 1 do write(A[i]);
  writeln(' ',f);
  readln;
  readln
end.

Ответить

Другие вопросы из категории

Черно-белая фотография разбита на точки, каждая из которых кодируется шестью битами информации. Каков информационный объем фотографий 5х8 см, если один

квадратный сантиметр содержит 1764 точки? Необходимо вычислить информационный объем в Кбайт смешанного документа (с точностью до сотых).

Читайте также

Цепочки символов (строки) создаются из букв латинского алфавита по следующему правилу: Первая строка состоит из двух символов – это буквы

«AB».

Каждая из последующих цепочек создается такими действиями: в начало записывается буква, следующая по алфавиту, далее записывается предыдущая строка и она же в обратном порядке символов (справа налево).

Вот первые 4 строки, созданные по этому правилу:

(1) AB

(2) BABBA

(3) CBABBAABBAB

(4) DCBABBAABBABBABBAABBABC

Сколько раз буква А встречается в 8-ой строке?

Дано слово "Процессор". Используя буквы входящие в это слово в качестве алфавита(буквы могут быть только прописными), были составлены все возможные слова

из четырех букв, такие что соседние буквы в каждом слове различны и все слова отличаются друг от друга хотя бы одной буквой. Слова, состоящие из одинаковых букв, но стоящих в разном порядке считаются различными. Сколько получилось таких слов? В ответе укажите целое число.
Можно пожалуйста с подробным решением?

1)В диапазоне от 0 до 100 подсчитать количество чисел оканчивающихся на 3.

2)В диапазоне от 0 до 50 подсчитать количество чисел сумма цифр которых равна 3.

Строки (цепочки латинских букв) создаются по следующему правилу. Первая строка состоит из одного символа - латинской буквы "А". Каждая из последующих

цепочек создается такими действиями: в очередную строку сначала записывается буква, чей порядковый номер в алфавите соответствует номеру строки (на i-м шаге пишется "i"-я буква алфавита), к ней слева и справа приписывается предыдущая строка. Вот первые 3 строки, созданные по этому правилу:
(1) A
(2) ABA
(3) ABACABA
Запишите шесть символов подряд, стоящие в седьмой строке со 122-го по 127-е место (считая слева направо).



Вы находитесь на странице вопроса "Вывести в обратном порядке последнее слово строки. Подсчитать количество букв в нем.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.