Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите пожалуйста) Написать программу: x=2y+3, при у=2, 4, 8, 16, 32, 64, 128.

10-11 класс

Mistiko21 16 июня 2013 г., 15:09:41 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Rait9
16 июня 2013 г., 16:01:22 (10 лет назад)

var
  x,y:integer;
begin
  y:=2;
  while y<=128 do begin
    writeln(y:6,2*y+3:6);
    y:=y*2
  end
end.

Тестовое решение:

     2     7
     4    11
     8    19
    16    35
    32    67
    64   131
   128   259


Ответить

Другие вопросы из категории

Помогите решить задачу на паскале, очень нужно:

Дана строка, удалить текст находящийся в скобках (вместе со скобками)

Я тут начал делать, вот только с удалением у меня ничего не получается, напишите как можно сделать

Вот как я делал:
program zd;
uses crt;
var s:string; i,l,n,t,y:integer;
begin
clrscr;
writeln('Введите строку');
readln(s);
l:=length(s);
for i:=1 to n do begin
if s[i]='(' then
t:=i; {здесь присваивал номер найденной скобки}
if s[i]=')' then
y:=i; {так же, как и выше}
delete (s,t,i); {у меня получается, что он удаляет с открывающей скобки и всё что находится вправо, а левая часть до скобки остается нетронутой}
end;
writeln('Данный результат =', s);
readln;
end.

Дана строка, содержащая путь к файлу или каталогу, записанный по соглашениям, принятым в ОС MS DOS. Преобразовать данную строку таким образом, чтобы она

содержала путь в формате ОС Unix, то есть заменить каждый символ "\" на символ "/".Путь DOS:

Подпрограммы, Pascal ABC

Дано массивы А1(N1,M1), A2(N2,M2), A3(N3,M3). Сформировать одномерные массивы В1, В2, В3, каждый из которых состоит из 2-ух элементов. В первом из них количество положительных элементов массивов А1,А2,А3 соответственно, во втором количество отрицательных элементов массивов А1,А2,А3 соответственно. Определение количества отрицательных и положительных элементов в исходном массиве и формирование одномерного массива осуществить в подпрограмме.

Иванов Иван хотел закачать себе на компьютер файл размером 2,2 Гбайта. Скорость закачки файла у него в сети была 310 Кбит/секунду. После того, как он

закачал ровно половину файла, скорость увеличилась в три раза. Какое время ему понадобится, чтобы скачать весь файл. Ответ записать в часах, округлив по математическим правилам до целых чисел

2.

Волк и волчонок, медведь и медвежонок, лис и лисёнок решили переправиться с
левого берега реки на правый берег. У них была лодка, в которую помещались
любые двое из них. Как им переправиться на другой берег, если нельзя оставлять
детёнышей с чужими родителями.





Читайте также

написать программу на Assembler

добрый вечер, всем. помогите, пожалуйста, написать программу на Ассемблере.

задание:
Создать программу на языке Ассемблер, что позволяет организовать вычисления над элементами массивов

Объединить два массива 8-битных целых чисел со знаком. Сначала элементы второго затем первого.

заранее огромное спасибо всем!

Помогите, Пожалуйста, с программой Паскаль. Рассмотрим целочисленный массив А[1..N] при N <= 100.

Написать программу, которая вычисляет среднее арифметическое элементов с четными индексами и среднее арифметическое с нечетными индексами.
Ввод: Число N и элементы массива вводятся из Файла.
Вывод: В файл должны быть введены 2 вычисленных значения

программа на C++ в визуальном режиме (есть несколько вариантов кода программы)

доброй ночи, уважаемые программисты и успевающие в учебе студенты. помогите, пожалуйста, написать программу на C++ (в визуальной вкладке).

ВОТ ЗАДАНИЕ:
дано три переменные вещественного типа. если их значения упорядочены по возрастанию или убыванию, то удвоить их; иначе заменить значение каждой переменной на противоположное. вывести значения переменных.


я прикрепила несколько тестовых файлов (блокнот) в которых есть несколько вариантов решение этого задание (то есть коды программ), а вы скажите какой из них лучше всего подходит, а также скажите какие компоненты нужно кинуть на форму-дизайн (то есть какие кнопки, и что на них писать). в этих 3 файлов есть написанный код программы, нужно написать: на какие кнопки что писать и какой вариант решение больше подходит.

заранее огромное спасибо всем за помощь!!!

Помогите пожалуйста написать программу в паскале.

Составить программу перевода натурального числа из десятичной системы счисления в двоичную

10-11 класс информатика ответов нет


Вы находитесь на странице вопроса "Помогите пожалуйста) Написать программу: x=2y+3, при у=2, 4, 8, 16, 32, 64, 128.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.