Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

HELP! :*

5-9 класс

написать программу, которая в последовательности целых чисел определяет среднее арифмитическое чисел кратных 4. Последовательность целых чисел заканчивается 0. Гарантируется,что в последовательности хотя бы одно число кратное 4

Jyliazharenikov 03 авг. 2014 г., 16:33:33 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
MagaMaga95
03 авг. 2014 г., 17:09:58 (9 лет назад)

Program n1;
Uses CRT;
Const n=10;
Var A: array[1..n] of integer;
i,k,s,m: integer;
begin;
randomize;
ClrScr;
Writeln('Ishodny massiv');
a[n]:=0;
m:=random(10);
For i:=n-1 downto 1 do
begin
a[i]:=a[i+1]+m;
write(a[i]:3);
If a[i] mod 4=0 then begin
k:=k+1; s:=s+a[i];
end;
end;
writeln;
Writeln('Srednee arifmeticheskoe =',s/k);
readln
end.

Ответить

Другие вопросы из категории

Придумайте примеры передачи информации,соответствующие следующим схемам: Ситуация _______________________________________ Источник > приемник

_________ ___________ Ситуация Источник > приемники _________ __________ Ситуация ____________________________________________ Источники > приемник Ситуация _____________________________________________ Источник-приемник < > приемник источник ___________________ _________________

помогите решить уравнение в паскале:

Читайте также

Help me! Please! 10 номер
Help!!! Help!!! Help!!!

1) Число 45 надо перевести в двоичную систему?

2) Двоичный код надо перевести в 16-ти разрядную систему 100101?

Please, help somebody!!! Помогите решить тест:)


Вы находитесь на странице вопроса "HELP! :*", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.