Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Разделить массив, заполненный случайным образом только положительными числами, на два - четных и нечетных. Составить блок схему и написать программу.

10-11 класс

Narutoport 30 окт. 2014 г., 19:58:36 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Fidanahmedova
30 окт. 2014 г., 20:56:01 (9 лет назад)

uses crt;
const n=10;
var a,b,c: array [1..n] of integer;
    x,y,z,k: integer;
begin
     y:=0;
     z:=0;
     for x:=1 to n do begin
         a[x]:=random(100)+1;
         if a[x] mod 2=0 then begin
            inc(y);
            b[y]:=a[x];
            end
            else begin
                 inc(z);
                 c[z]:=a[x];
            end;
         write(a[x]:4);
     end;
     writeln;
     k:=y;
     for y:=1 to k do
         write(b[y]:4);
     writeln;
     k:=z;
     for z:=1 to k do
         write(c[z]:4);
end.

+ 0 -
TanyaShlapak98
30 окт. 2014 г., 23:33:33 (9 лет назад)

program test;
var i,k,z:integer;
m:array[1..100] of integer;
c:array[1..100] of integer;
n:array[1..100] of integer;
begin
randomize;
for i:=1 to 10 do
begin
m[i]:=random(1000); 
if m[i] mod 2 =0  then 
begin 
k:=k+1; 
c[k]:=m[i]; 
end 
else 
begin  z:=z+1; 
n[z]:=m[i]; 
end;
end;
for i:=1 to z do
write('     НЕЧЕТНЫЕ',n[i]);
writeln();
writeln();
for i:=1 to k do
write('      ЧЕТНЫЕ',c[i]);
end.

+ 0 -
Smileos
31 окт. 2014 г., 1:57:02 (9 лет назад)

паскаль?

+ 0 -
336
31 окт. 2014 г., 3:01:17 (9 лет назад)

Да, паскаль.

+ 0 -
Koroleva56
31 окт. 2014 г., 5:22:11 (9 лет назад)

А массив одномерный?

+ 0 -
Kolbina
31 окт. 2014 г., 7:23:43 (9 лет назад)

Да, одномерный.

+ 0 -
Iuliaaa
31 окт. 2014 г., 9:15:54 (9 лет назад)

разве решение неправильная?

Ответить

Другие вопросы из категории

Два текста на русском языке записаны в различных кодировках. Первый текст состоит из 240 символов и записан в 16-битной кодировке Unicode, второй текст сос

тоит из 120 символов и записан в 8-битной кодировке КОИ-8. Во сколько раз количество информации в первом тексте больше, чем во втором?
1)5 2)2 3)3 4)4

помогите сделать по прикладному программированию.

задание: вычислить значение функции

Читайте также

1.Одномерный массив заполнен случайным образом. Найти количество четных элементов. 2. Одномерный массив размерностью N , где N -нечетное число,

заполнен случайными числами от -15 до 6. Все , числа кратные 3 заменить на противоположные.

составьте блок-схему и программу для решения следующей задачи. Введите с клавиатуры два числа: к и л. Если они положительны, то замените каждое на квадрат

их суммы и выведите результаты на экран. Если все числа отрицательны, то каждое сделайте равным наименьшему и выведите результаты. Иначе, К приравняйте к 10, а Л - к 15 и выведите результаты

Помогите решить, очень нужно... 2. Составьте блок-схему алгоритма(её не надо) и программу вычисления в массиве A(10) количества положительных

элементов.
3. Составьте программу заполнения массива, не используя клавиатуру, числами: 1, 3, 5, 7, 9, 11, 13, 15, 17, 19.

составить блок схему по программе pascal program zadacha 3_1. var max,x,e:real; begin writeln('введите натуральное число x');readln(x);

writeln('введите число y');readln(y); if x>y then max:=x else max:=y; writeln('большее из двух =',max); end.



Вы находитесь на странице вопроса "Разделить массив, заполненный случайным образом только положительными числами, на два - четных и нечетных. Составить блок схему и написать программу.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.