Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

1) Удвоить все элементы массива. 2)Найти сумму элементов двух массивов одинаковой размерности. 4) Найти Минимальные элементы массива и

5-9 класс

его индекс.

5) Найти максимальные элементы среди положительных элементов массива 6) Найти максимальные элементы среди отрицательных элементов массива

7) Определить количество максимальных элементов массива

P.S Ребят, все в паскале...заранее спасибо=*

Rymzin4 02 мая 2014 г., 5:56:23 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
V41099
02 мая 2014 г., 8:47:01 (9 лет назад)

var

a:array[1..10,1..10] of integer;

b:array[1..10,1..10] of integer;

sum:array[1..10,1..10] of integer;

pol,otr,max,min:real;

i,j,indexi,indexj:integer;

begin

min:=0;

 max:=0;

randomize;

for j:=1 to 10 do

begin

 for i:=1 to 10 do

begin

randomize;

 

 a[i,j]:=random(51);

randomize;

 

 b[i,j]:=random(51);

 a[i,j]:=a[i,j]*2;

writeln(a[i,j]);

a[i,j]:=a[i,j]/2;

end;

end;

for j:=1 to 10 do

begin

for i:=1 to 10 do

begin

a[i,j]:=a[i,j]+b[i,j];

writeln(a[i,j]);

a[i,j]:=a[i,j]-b[i,j];

end;

end;

for j:=1 to 10 do

begin

for i:=1 to 10 do

begin

if a[i,j]<min then

begin

 

 min:=a[i,j];

 indexi:=i;

 indexj:=j;

 end;

end;

end;

writeln(min,indexi,indexj);

for j:=1 to 10 do

begin

 

 for i:=1 to 10 do

 begin

if (a[i,j]>0) and (a[i,j]>max) then

max:=a[i,j];

end;

end;

writeln(max);

max:=0;

for j:=1 to 10 do

begin 

for i:=1 to 10 do

begin

 

if (a[i,j]<0) and (a[i,j]>max) then max:=a[i,j];

end;

end;

writeln(max);

end.

 

 программа выполняет сразу все 7 пунктов. Значения задаются сами. На выходе с каждой строки Вы получите каждый пункт задания.

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

+ 0 -
Bratyshko1998
02 мая 2014 г., 9:51:48 (9 лет назад)

Если в Паскале:

for i:=1 to n do

a[i] = a[i]*2;

for i:=1 to n do 

writeln(a[i]);

Ответить

Читайте также

Массив В задан случайным образом а) подсчитать сумму элементов массива, меньших своего номера; б) подсчитать сумму элементов массива, стоящих на четных

местах; в) подсчитать сумму отрицательных элементов массива; г) подсчитать сумму элементов массива, больших произвольного числа К. помогите, пожалуйста

Заполните массив с клавиатуры целыми числами и найдите сумму элементов массива с i1-го по i2-й (i1 и i2 вводить с клавиатуры).

Входные данные:
в первой строке целое число n (0 < n ≤ 100) - кол-во элементов в массиве и целые числа i1 и i2 (0 < i1, i2 ≤ 100). Во второй строке целые числа Х1, Х2,..,Хn разделенные пробелом (числа по модулю не превосходят 32000) - значения элементов массива.

Выходные данные:
сумма элементов массива c номерами от i1 до i2.

(Написать программу на Паскале)

1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива.

2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива.
3. Массив из 5 целых чисел вводится с клавиатуры в строку. Найти сумму элементов массива, стоящих на чётных позициях. Вывести исходный массив и полученную сумму.
4. Массив из 40 целых чисел из промежутка [10,90] задается с помощью генератора случайных чисел. Найти сумму элементов массива, кратных n . Вывести исходный массив и полученную сумму.
Помогите кто в чем может.

Даю много баллов!ПАСКАЛЬ!Только решите!С подробной записью всей программы и ответом!Даны 2 массива А и В по 20 элементов.Сформировать массив с=А+В,в

полученном массиве найти сумму элементов,имеющих чётный индекс.Запишите подробно всю прграмму...Прошу.Работаем с Паскалем(((

Помогите пожалуйста ! срочно надо!!!...в заданной последовательности целых чисел определите сумму элементов кратных 10! пример задачки вот именно под

типо по такой же системе которую щас напишу! program Maximum; i,n,max:integen; begin writeln ( 'введи элементы массива для поиска максимума'); for i:=1 to 10 do begin write ('a [', i ,']=');readln (a [ i ] ) ;end; max:=a[1]; for i = 2 to 10 do if a [ i ] > max then begin max:=a [ i ] ; n:= i ; end; writeln ('найти наибольший элемент ',max ,' под номером ', n); вот наподобие этого примера нужно построить мою задачу! в заданной последовательности целых чисел определите сумму элементов кратных 10. Помогите пожалуйста!!!



Вы находитесь на странице вопроса "1) Удвоить все элементы массива. 2)Найти сумму элементов двух массивов одинаковой размерности. 4) Найти Минимальные элементы массива и", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.