Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Заполните массив с клавиатуры целыми числами и найдите сумму элементов массива с i1-го по i2-й (i1 и i2 вводить с клавиатуры).

5-9 класс

Входные данные:
в первой строке целое число n (0 < n ≤ 100) - кол-во элементов в массиве и целые числа i1 и i2 (0 < i1, i2 ≤ 100). Во второй строке целые числа Х1, Х2,..,Хn разделенные пробелом (числа по модулю не превосходят 32000) - значения элементов массива.

Выходные данные:
сумма элементов массива c номерами от i1 до i2.

(Написать программу на Паскале)

Baters1199 23 апр. 2013 г., 1:05:08 (11 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ainura1992
23 апр. 2013 г., 2:43:00 (11 лет назад)

var
 a:array [1..100] of longint;
 N,i1,i2,i,S:longint;
begin
 Read(N,i1,i2);
For i:=1 to N do Read(a[i]);
For i:=i1 to i2 do S:=S+a[i];
Write(S);
end.

+ 0 -
Snejok163
23 апр. 2013 г., 3:42:56 (11 лет назад)

за 9 баллов такую программу писать лень:D

Ответить

Другие вопросы из категории

Выполните операцию сложения над двоичными числами:

а) 101010+1101;
б) 1010+1010;
в) 10101+111.

найдите произведение 1*2*3*...*15
Задача 1 Определить кол-во цифр в числе .

Задача 2 Напечатать те натуральные числа квадрат которых не превышает n .
Задача 3 Найти первое натуральное число куб которого больше n .

Читайте также

Массив В задан случайным образом а) подсчитать сумму элементов массива, меньших своего номера; б) подсчитать сумму элементов массива, стоящих на четных

местах; в) подсчитать сумму отрицательных элементов массива; г) подсчитать сумму элементов массива, больших произвольного числа К. помогите, пожалуйста

1.Вставьте пропущенные слова в описании массива А, элементами которого являются целые числа. А: _________________[1..100] of ______________.

2. Опишите массив для хранения зарплаты за каждый месяц. Зарплату считать целым числом.

3.Опишите: a)Переменную В для массива, состоящую из 8 символов. b)Переменную MAS для массива, состоящего из 100 вещественных чисел. c)Переменную DAY для массива, состоящего из 30 целых чисел, причем номер первого элемента массива должен быть равен 5

.4. Пусть А : array [1..10] of integer. Напишите операторы, соответствующие следующим действиям: a. Третий элемент массива сделать равным 5. b. Вывести на экран 7-й элемент массива. c. Ввести значение 1-го элемента массива. d. Вычислить сумму 1,2 и 3-го элементов массива.

5. Пусть А : array [1..15] of real. Напишите операторы, соответствующие следующим действиям, при необходимости используя дополнительные переменные: Вычислить сумму всех элементов массива (используйте цикл).

6. Пусть C : array [1..10] of integer. Напишите операторы, соответствующие следующим действиям, при необходимости используя дополнительные переменные: Вывести на экран все элементы массива.

7. Пусть А : array [1..15] of real. Напишите операторы, соответствующие следующим действиям, при необходимости используя дополнительные переменные: Поменять местами первый и последний элементы массива.

8. Пусть В : array [1..20] of integer. Напишите операторы, соответствующие следующим действиям, при необходимости используя дополнительные переменные: Заполнить массив случайными числами из интервала [-24;37].

1. Дан массив А из 10 элементов, которые заполняются случайным образом, числам от 0 100. Выведите массив на экран и найдите максимальный элемент массива.

2. Создать массив A из 10 элементов, заполненный случайным образом числами принадлежащих промежутку (0;20). Вывести полученный массив на экран. Вычислить количество элементов массива, значения которых не превышают среднее арифметическое значений его элементов.

1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива.

2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива.
3. Массив из 5 целых чисел вводится с клавиатуры в строку. Найти сумму элементов массива, стоящих на чётных позициях. Вывести исходный массив и полученную сумму.
4. Массив из 40 целых чисел из промежутка [10,90] задается с помощью генератора случайных чисел. Найти сумму элементов массива, кратных n . Вывести исходный массив и полученную сумму.
Помогите кто в чем может.

Ребят помогите плиз только начали изучать массивы надо решить задачу!

на паскале:
заполнить массив из 12 целых числе данных из клавиатуры.Найти сумму и кол-во всех отрицательных числе массива, заменить все числа которые больше десяти нулями.Вывести полученный массив на экран.
СПС за ранее как можно быстрее!



Вы находитесь на странице вопроса "Заполните массив с клавиатуры целыми числами и найдите сумму элементов массива с i1-го по i2-й (i1 и i2 вводить с клавиатуры).", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.