Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Заполнить

10-11 класс

массив случайными числами (положительными и отрицательными) из произвольного
диапазона. Вывести созданный массив на экран, расположив элементы в одну строку
через пробелы. Заменить все отрицательные элементы квадратом соответствующего
индекса

DANCEE 15 янв. 2014 г., 10:31:09 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Оз45
15 янв. 2014 г., 11:56:06 (10 лет назад)

const
  n = 15;

var
  i: integer;
  a: array[1..n] of integer;

begin
  Randomize;
  writeln('Исходный массив');
  for i := 1 to n do
  begin
    a[i] := Random(100) - 50;
    write(a[i]:6);
    if a[i] < 0 then a[i] := sqr(i)
  end;
  writeln;
  writeln('Результирующий массив');
  for i := 1 to n do write(a[i]:6);
  writeln
end.

Тестовое решение:

Исходный массив
     3    37    40    17    20   -12   -27     4    34    -1     9    42    -6   -36    28
Результирующий массив
     3    37    40    17    20    36    49     4    34   100     9    42   169   196    28



Ответить

Другие вопросы из категории

Известно, что качество звукозаписи

характеризуется параметром потока данных в секунду (бит/сек, кбит/сек). Если
принять, что качество звука установлено в 73728 бит/сек, определите, какой
объем в байтах займет файл 8 секундной аудиозаписи без сжатия


Получив на вход число х, этот алгоритм печатает два числа К и R. Укажите наименьшее из таких чисел х, при вводе которых алгоритм печатает сначала 4, а

потом 3.
var x, i, K, R, y: integer;
begin
readln(x);
K := 0; R := 9;
y := x mod 10;
while x > 0 do begin
K := K + 1;
if R > x mod 10 then
R := x mod 10;
x := x div 10
end;
R := y - R;
writeln(K); writeln(R)
end.

Читайте также

(Программа Паскаль) 1)Заполните массив элементами арифметической прогрессии. Её первый элемент и разность нужно ввести с клавиатуры. 2)

Заполните массив степенями числа 2( от 2(в первой степени) до 2(в N степени)

1)заполнить массив из 15 элементов числами из интервала от -10 до 10 вывести в строчку и повторно вывести в строчку,заменив все четные элементы на число

100.
2) Заполнить массив целыми положительными и отрицательными числами из интервала [-10;10] и вывести его в строчку. Поменять знаки элементов массива на противоположные и повторно вывести массив на экран в строчку.
Пожалуйста,помогите,очень срочно!!!



Вы находитесь на странице вопроса "Заполнить", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.