Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Написать в Паскаль.

10-11 класс

Двухмерный массив размером M*N заполнить случайными целыми числами в интервале от -90 до 0. Вывести полученный массив на экран в виде таблицы. Найти количество элементов кратных 4 в последней строке.

маленькая1919 02 нояб. 2014 г., 7:59:22 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Daryakorovina
02 нояб. 2014 г., 9:36:03 (9 лет назад)

const
  n = 5; m = 5;

var
  a: array [0..m, 0..n] of shortint;
  i, b, c: integer;

begin
  for i := 1 to m do
  begin
    for b := 1 to n do
    begin
      a[i, b] := random(-90, 0);
      write(a[i, b]:4);
      if (i = m) then
        if (a[i, b] mod 4 = 0) then
          c += 1;
    end;
    writeln((i = m) and (b = n) ? ' ' + c : '');
  end;
  writeln();
end.

+ 0 -
Yusup2233
02 нояб. 2014 г., 10:09:31 (9 лет назад)

var a:array [1..200,1..200] of integer;
i,k,m,n:integer;
begin
writeln ('Введи размерность массива');
readln (m,n);
for i:=1 to m do begin
for j:=1 to n do begin
a[i,j]:=random(91)-90;
write (a[i,j]:4);
end;
writeln;
end;
for j:=1 to n do
if a[m,j] mod 4=0 then inc(k);
writeln (k);
readln;
end.

Ответить

Другие вопросы из категории

Для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты. Если все числа не превышают 30, то выведите их

удвоенное произведение. Если последнее число четно, то выведите произведение первых двух чисел, уменьшенное в 10 раз.
Решить нужно на среде С или С++
Заранее спасибо.

3. Не используя функцию возведения в квадрат, напишите на языке Паскаль наиболее короткие алгоритмы вычисления а) y=x¹° б)y=x¹⁵ или а) y=x^10

б)y=x^15

Постараться использовать минимальное количество дополнительных переменных.

4. Запишите на языке Паскаль программу циклического обмена значениями трёх переменных a,b,c. Схема циклического обмена: a ← b ← c. Например, если до обмена было: a=1, b=2, c=3, то после обмена должно стать: a=2, b=3, c=1.

Читайте также

Написать в Паскаль программу для решения следующей задачи.

Вводится строка, состоящая только из цифр без нуля. Написать пользовательскую функцию, которая возвращает строку , добавляя после каждого символа символ '0'.

Помогите написать решение Паскаль в ALGO. Задание 1) Для заданного X вычислить значение функций: Y= 1) корень из X в квадрате, если

x=2

2) "нет решений", если x=0

3) 3x в квадрате минус 5, если X=3,4,5,6.

Задание 2) - Составить алгоритм и программу

Написать программу, которая определяет по последней цифре числа последнюю цифру его квадрата.

Прошу написать полное решение программы,

Спасибо Заранее

Написать программу Паскаль))) срочно!)))

Ввести с клавиатуры натуральное число.написать программу, которая определяет, кратна ли сумма его цифр 6.

Написать программу ПАСКАЛЬ вычисления расстояния между населёнными пунктами. 1)Вычислите расстояние между населёнными пунктами. 2)введите

исходные данные

3)масштаб карты 120 (кол-во км в одном см)

4)расстояние между точками изображающими населённые пункты если между ними 3.5 (см)...(должно выйти 420км)

5) расстояние между насел. пунктами ... км

Напишите пожалуйста программу. К завтрашнему дню надо. С Паскалем проблемы



Вы находитесь на странице вопроса "Написать в Паскаль.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.