Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

напишите программу удаляющая из текста все буквы совпадающие с его последней буквой

5-9 класс

Crazymazai 21 мая 2013 г., 13:20:11 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nataliaminaev
21 мая 2013 г., 15:46:25 (10 лет назад)

uses crt;
var s:string;
n,i:integer;
begin
readln(s);
n:=length(s);
for i:=1 to n do
if s[i]=s[n] then delete(s,i,1);
writeln(s);
end.

Эта программа рассчитана на то, что удаляется и последний символ тоже

+ 0 -
Rasulov050998
21 мая 2013 г., 18:34:34 (10 лет назад)

var s:string; i:integer;
begin
read(s);
i:=1;
while i<length(s) do
if s[i]=s[length(s)] then s:=copy(s,1,i-1)+copy(s,i+1,length(s)-i)
else i+=1;
write(s)
end.

+ 0 -
Twi
21 мая 2013 г., 20:19:53 (10 лет назад)

решишь?

+ 0 -
Zondark
21 мая 2013 г., 21:28:22 (10 лет назад)

а то мне , кровь из носа, надо

+ 0 -
2001555111
21 мая 2013 г., 22:37:37 (10 лет назад)

На паскале?

+ 0 -
Katya272015
22 мая 2013 г., 0:46:16 (10 лет назад)

да

+ 0 -
Чудиковна
22 мая 2013 г., 2:28:00 (10 лет назад)

АВС

Ответить

Другие вопросы из категории

Помогите! Плиииз!

Ваш приятель Дима живёт в доме, в котором 8 квартир. Вы не знаете, в какой именно квартире он живёт. Подойдя к дому, вы встретили девочку, которая знает номер квартиры Димы, но после каждого вопроса лишь кивает головой "да" или мотает "нет". Какое наименьшее количество вопросов необходимо задать девочке, чтобы узнать номер квартиры Димы?

Три подруги вышли на прогулку в туфлях и платьях белого, зеленого и синего

цветов. Известно, что только у Ани цвета платья и туфель совпадают. Ни туфли,
ни платье Вали не белые. Наташа в зеленых туфлях. Определите цвет платья и
туфель каждой из подруг.
Помогите решить пожалуйста(спасибо)

Читайте также

а)Одномерный массив A заполнен десятью случайными целыми числами от 1 до 20. Напишите программу вывода элементов массива в обратном порядке.

б)Напишите программу, которая массив из 20 элементов заполнит неповторяющимися целыми числами и выведет на экран элементы с нечетными индексами.

РЕШИТЕ ХОТЬ ЧТО-НИБУДЬ!!!:з 1.Линейные программы Напишите программу на ШАЯ.Вычислите значения следующих выражений: f=t*t/2+t

2.Условный оператор(ветвление)

Нарисуйте блок-схему.Дано два числа.Верно ли, что он равны?

3.Циклы

Напишите программу на Паскале. Выведите на экран табицу умножения на 4 в виде 1+4=4,2+4=8,....9*4=36.

4.Одномерные массивы

Напишите программу на Паскале.Подсчитайте количество максимальных элементов массива А [1..12].

5.Двумерные массивы

Напишите программу на Паскале. создать массив случайны чисел В[1..6,1..6].Все элементы массива, расположенные выше главной диагонали сделать равными О.Вывести исходный и исправленный массивы.

Напишите программу для вывода на экран последовательности символов: ABBCCCDDDD…ZZZZZZZZZZZZZZZZZZZZZZZZZZ Напишите программу, которая выводит «Да», если

буква «а» встречается в тексте чаще, чем буква «о», и «Нет» в обратном случае. Поменяйте местами k первых и k последних символов строки. Удвойте вхождение буквы в текст. Например, если пользователь ввёл текст «мама мыла раму» и выбрал для удвоения букву «м», то после работы программы должно быть выведено на экран сообщение «ммамма ммыла рамму» Проверьте написанный текст на правильность написания сочетаний «жи», «ши». Если слова написаны с ошибкой – исправьте их. Удалите в каждом слове предложения первую и последнюю букву.

Напишите программу, выводящую слова«зачет», если введено число 3, 4 или 5 и

«незачет», если введено число 1 или 2.
Напишите программу, выводящую текст «плохо», «удовлетворительно», «хорошо»
или «отлично», если введено число 2, 3, 4 или 5 соответственно.
РЕШИТЕ ПОЖАЛУЙСТА

Помогите по программе paskal : 1.дано целое число.напишите программу которая уменьшает на 2 модуль этого числа и выводит на экран монитора

результат

2.дано целое число.напишите,программу которая выводит на экран последнюю цифру данного числа,затем возводит ее в квадрат и выводит на экран монитора результат



Вы находитесь на странице вопроса "напишите программу удаляющая из текста все буквы совпадающие с его последней буквой", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.