Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

найти частное произведений четных и не четных цифр четырехзначного числа n

10-11 класс

Nagornyya 02 июня 2014 г., 11:20:59 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Lleer
02 июня 2014 г., 13:36:54 (9 лет назад)

Есть книжка такая, "Песни о Паскале". Глава 47.

Нужно разложите число на цифры и вычислить соответствующие произведения,
flag: false; m1: = 1; m2: = 1;
while N <> 0 do begin
if flag then m1:= m1*(N mod 10) else m2:= m2*(N mod 10);
flag:= not flag;
N:= N div 10;
end;
if m1<>0 then Writeln(m2 div m1) else Writeln('Бесконечность');

+ 0 -
викаа97
02 июня 2014 г., 14:20:27 (9 лет назад)

var
  i,n,x:integer;
  a:array[1..4]of integer;
begin
readln(n);
for i:=4 downto 1 do
  begin
  x:=n mod 10;
  a[i]:=x;
  n:=(n-x) div 10;
  end;
writeln('Произведение четных: ',a[2]*a[4]);
writeln('Произведение нечетных: ',a[1]*a[3]);
end.

Если можно использовать строковые функции, то будет проще:
var
  i:integer;
  n:string;
  a:array[1..4]of integer;
begin
readln(n);
for i:=1 to 4 do a[i]:=StrToInt(n[i]);
writeln('Произведение четных: ',a[2]*a[4]);
writeln('Произведение нечетных: ',a[1]*a[3]);
end.

Ответить

Другие вопросы из категории

Размер черно-белого изображения 10*15 см. Изображение имеет 256 градаций яркости (оттенков серого). Для хранения изображения в несжатом виде

требуется 3750 Килобайт. Разрешение изображения составляет (?) точек на дюйм (1 дюйм = 2,5 см)

классификация антивирусных программ
Ввести строку. На печать

выдать слова, имеющие длину большую, чем длина первого слова строки.

Читайте также

PASAL

написать программу вычисляющую произведение второй и четвертой цифр четырехзначного числа.

1.Среди цифр четырехзначного числа есть четная. Накидал тут решение, но где-то ошибка, не могу

понять где

var
t,s,d,e,i: integer;
begin
for i:= 1000 to 9999 do
t:=i div 1000;
s:=(i div 100)mod 10 ;
d:=(i div 10) mod 10;
e:=i mod 10;
if ((t mod 2=0) or (s mod 2 =0) or (d mod 2 =0) or (e mod 2=0)) then writeln ('TRUE') else writeln ('FALSE');
end.

Паскаль

Найти произведение двух средних цифр четырехзначного числа.

Срочно! Дано трехзначное число. Если сумма цифр этого числа превышает 15, то вывести эту сумму. Иначе вывести

произведение цифр этого числа.

Необходимо решение на языке Паскаль. Заранее спасибо!



Вы находитесь на странице вопроса "найти частное произведений четных и не четных цифр четырехзначного числа n", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.