Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите пожалуйста! напишите программу паскаль. вроде циклы

5-9 класс

Дано натуральное число N. Определить, является ли оно совершенным. Совершенное число N равно сумме его делителей, не превосходящих само N.

Аннушка333 04 дек. 2013 г., 11:08:30 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
бобер45
04 дек. 2013 г., 13:47:59 (10 лет назад)

program gt;
var n,s,l,i:longint;
begin
read(n);
s:=0;
l:=round(sqrt(n));
for i:=1 to l do
begin
if(n mod i=0)then begin
s:=s+i;
s:=s+n div i;
end;
end;
if(l*l=n)then s:=s-l;
if(s<=n)then writeln('ДА ЭТО ПРАВДА')else writeln('НЕТ');
end.
2)
program gt;
var n:integer;
begin
read(n);
if(n=1)then writeln('ДА')else writeln('НЕТ');
end.
3)
program gt;
var n,s:integer;
begin
read(n);
s:=((1+n)*n)div 2;
writeln(s);
end.

+ 0 -
Vladnikonov20
04 дек. 2013 г., 15:11:49 (10 лет назад)

по-моему эта легче)

+ 0 -
Rrr152
04 дек. 2013 г., 16:40:28 (10 лет назад)

сумму натуральных которые начинаются с 1 и по возрастанию(1 2 3 ..)?

+ 0 -
Gosha324578447
04 дек. 2013 г., 18:26:47 (10 лет назад)

а все

+ 0 -
HaPpYDima
04 дек. 2013 г., 20:04:11 (10 лет назад)

3 способ посмотри

+ 0 -
Сильвия123456789
04 дек. 2013 г., 21:57:41 (10 лет назад)

СПАСИБО ОГРОМНОЕ!!!

Ответить

Другие вопросы из категории

Помогите, пожалуйста)

Перевести следующие числа из "10" с.с в "2", "8", "16" с.с.:а) 463; б) 1209; в) 362; г) 3925; д) 11355.

Индивидуальные номера страховых медицинских свидетельств жителей в некоторойстране содержат только цифры 1, 3, 5, 7 и содержат одинаковое количество цифр,

а имен-но 3 цифры. Известно, что медицинскую страховку имеют абсолютно все жители и номе-ра всех свидетельств различны. Каково максимально возможное количество жителей встране?1) 64 2)12 3) 81 4) 60

В классе учится три мальчика, занимающихся спортом: Петя, Тимофей и Вася. На вопрос: «Кто из ваших учеников играет в баскетбол?». Учитель физкультуры

ответил, двумя высказываниями, которые заведомо истинны:«Неверно, что Вася играет в баскетбол только с Тимофеем или оба не играют.»«Неверно, что если Петя не играет в баскетбол, то Тимофей в него играет.»Определите, кто из учеников учителя физкультуры играет в баскетбол.

Читайте также

Помогите,пожалуйста,написать программу по информатике.Вот такое условие:

Составьте программу, которая формирует массив из 40 случайных целых чисел от 0 до 20 и вычисляет:
1). сумму чисел, не превышающих 10;
2). сумму чисел,кратных 3. Помогите пожалуйста,написать эту программу на PaskalABC.

1)Напишите программу,которая запрашивает значения двух переменных и выводит их разность.Приглашение к вводу каждого числа произведите в отдельных

строках.Вывод результата сопроводите пояснениями
2)Напишите программу ввода трех величин( А,В,С) на одной строке,рассчитайте и выдайте на экран на отдельной строке значение выражения: (А*В)/3,14 +3С.
3)Напишите программу вычисления длины окружности и площади круга одного и того же заданного радиуса R.
Решать на паскале...Помогите пожалуйста(((



Вы находитесь на странице вопроса "Помогите пожалуйста! напишите программу паскаль. вроде циклы", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.