Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

В ПАСКАЛЕ. Задана арифметическая прогрессия (13, 10,...) Если ее член меньше 0,то вывести его порядковый номер.

5-9 класс

Olga0477 05 февр. 2014 г., 0:31:37 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Svistun2003
05 февр. 2014 г., 3:06:05 (10 лет назад)

var number, position, d : integer; begin number := 13; d := -3; position := 1; if d > 0 then writeln('Нет необходимого числа') else while number >= 0 do begin number := number + d; position := position + 1; end; writeln('Позиция: ', position); end.

+ 0 -
Sevilyaseytasa
05 февр. 2014 г., 3:41:16 (10 лет назад)

а до какого члена арифметической прогрессии считать? до бесконечности?

Ответить

Другие вопросы из категории

автоматическое устройство имеет один вход,можно подавать на него натуральные числа или последовательности символов и наблюдать результат на выходе. По

таблице наблюдений определите тип входных данных и правило, по которому осуществляется их преобразование

Читайте также

Пожалуйста помогите!! очень срочно, нужно написать программу скорей всего мне кажется в паскале

1. Writel(' вести стоимость перчатки наприм')
read (x)
2 стоимость сумки- наприм.
3.стоимость ремня- наприм.
4.если общая сумма больше 800р, то вывести сумму с учетом 10% скидки
5.если сумма меньше 800р, то вывести сумму
Помогите пожалуйста очень нужно, благодарю!!!

2. Определить, делится ли введенное число "а" на 3. Если делится то вывести на экран "Число делится на 3".Тип переменной определить самостоятельно. При

составлении условия учесть, что если число делится на 3, то то остаток от деления на 3 должен быть равен 0.

3. Дана программа на языке Паскаль.
var a,n,s: integer;
begin
s:=0;
n:=0;
repeat;
write('Введите число ');
readln(a);
s:=s+a;
n:=n+1;
until s>100;
writeln('Количество введенных чисел = ' ,n);
end.
Переписать программу используя цикл While.

4. Вывести на экран массив целых чисел, Состоящий из 15 элементов, значение которого из которых сгенерировано случайным образом из диапазона [20,60].

1.Составить программу в паскале,которая предлагает Ивану -Царевичу выбрать правильное направление пути.У Ивана-Царевича есть три варианта дальнейшего

пути:

направо,-"Коня потеряешь"

налево,-"голову сложишь"

вперёд,-"невесту найдёшь"

2.Составить прогрмму,которая определяет положительное число или отрицательное.

3.Дано целое число А.Если значение А>0,то необходимо его уыеличить на единицу.Если В<0,то уменьшить на единицу.

Зарание спасибо :)



Вы находитесь на странице вопроса "В ПАСКАЛЕ. Задана арифметическая прогрессия (13, 10,...) Если ее член меньше 0,то вывести его порядковый номер.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.