Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Прошу помогите написать программу в Паскале)

5-9 класс

С клавиатуры ввели число. Если это число нечетное, то нужно найти сумму чисел в диапазоне от 1 до этого числа, иначе вывести сообщение о том, что число нечетное.

Vladimir1958 26 нояб. 2014 г., 2:25:43 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Natca
26 нояб. 2014 г., 4:49:50 (9 лет назад)

Заметим, что числа образуют арифметическую прогрессию, а её сумма известна:
S= \frac{a_1+a_n}{2}\times n= \frac{1+n}{2}\times n
Поэтому два варианта программы: один вычисляет сумму накоплением, второй сразу определяет результат по формуле. Хороший пример того, что программист должен знать математику.

var
  n, i, s: integer;

begin
  Write('Введите натуральное число: ');
  Readln(n);
  if (n mod 2) = 0 then
  begin
    s := 0;
    for i := 1 to n do s := s + i;
    Writeln('Сумма чисел от 1 до ', n, ' равна ', s)
  end
  else Writeln('Введено нечетное число')
end.

Тестовое решение:

Введите натуральное число: 8
Сумма чисел от 1 до 8 равна 36

var
  n, s: integer;

begin
  Write('Введите натуральное число: ');
  Readln(n);
  if (n mod 2) = 0 then
    Writeln('Сумма чисел от 1 до ', n, ' равна ', ((1 + n) * n) div 2)
  else Writeln('Введено нечетное число')
end.

Тестовое решение:

Введите натуральное число: 8
Сумма чисел от 1 до 8 равна 36




Ответить

Другие вопросы из категории

Turbo Pascal

Дан одномерный массив А(i), i = 15, заданный случайным образом. Вывести на экран массив, значения которого находятся в диапазоне [-20;20]

Читайте также

Помогите написать программу для Паскаля.

1. Написать программу нахождения произведения n чисел.

1)найти сумму первых k последовательных нечетных чисел. написать программу в паскале. 2)вывести на экран натуральные нечетные числа от 5 до 55.тоже

паскаль 3)найти произведение последовательных натуральных чисел от n до m. написать программу паскаль. 4)найти сумму последовательных натуральных чисел от 10 до 15.тоже паскаль

Помогите написать программу на Паскале.

Напишите программу, которая в последовательности целых чисел
вычисляет сумму всех чисел, которые кратны 6 или 11. Программа получает на вход
целые числа, количество введённых чисел неизвестно, последовательность чисел
заканчивается числом 0 (0 – признак окончания ввода, не входит
в последовательность).

Количество чисел не превышает 1000. Введённые числа по
модулю не превышают 30 000.

Программа должна вывести одно число: сумму всех чисел,
которые кратны 6 или 11.






Ребятки помогите плз 75 баллов дам!!!!

помогите написать программу в паскале.
а-3х значное число с клавиатуры. если оно перевёртыш печатать "да" если иначе "нет"
спасибо,

Ребят) Помогите с программой на Паскале, пожалуйстаа)

Нужно написать программу, которая выводит на экран все двухзначные числа, делящиеся на 3 или на 5 (использовать операции целочисленного деления div или mod)



Вы находитесь на странице вопроса "Прошу помогите написать программу в Паскале)", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.